Adding ESP8266 stuck on “waiting for board to connect”

First time user… Sounds good, but no love.
I’m working with a MacBook Pro, Mid 2012, running macOS Catalina v 10.15.7

I’ve spent several hours today trying to get my ESP8266 devices to connect to Cayenne online. I’ve tried two NodeMCUs and one WeMos D1 Mini that all get stuck on “waiting for board to connect” and the wizard never gives me a script to plug-in (unlike it did for an Arduino I was able to connect but don’t wish to use in my project). If I go get a script off of GitHub and plug-in username/password/client I can connect and get the channel 0 data but it never completes the connection and I don’t get an “Install Complete” confirmation email like I did on the nano. Searching the forum, it appears I’m the only person that’s ever had this problem.

I also can’t add any new devices/widgets as it tells me to “please turn on the device“ and the “select device” only shows the Arduino, not any of the ESP devices. I tried adding a virtualWrite statement to my code, but can’t figure out how to add a channel online.

Lastly, I cannot find any way to delete devices or projects on the webpage, only add new. I’d have to say I’m a bit frustrated.


you can add a new arduino device and replace this client id into the esp8266 code you using. This way you can use all the generic devices which the arduino supports.

Thanks for trying to provide a work-around but the provided sketch for my Arduino device I was trying to add never completed uploading and my Nano 33 IoT is now bricked. I give up… on to something else.

Post your code i have some esp8266’s on cayenne

1 Like