Connection problem with Mega/Ehernet5100


I am having trouble connecting to my Arduino mega and Ethernet5100. I have other projects working fine so I dont think it will be a router issue, but I have tried to build this one twice - with the same result.
Basically I get a successful connection initially but when it tries to update from the dashboard (I think), it hangs with connecting to

Attached are a screen shot of the dash board and the serial output.

I have built the dashboard twice, the second time I tried each button as I added it to the dashboard and all worked fine - but this morning the same problem! I have commented out everything in my code except the basic Cayenne stuff in case that was the problem. But to no avail.
I am after any suggestions as to where to go from here!


Hi @cr.stubbs,

Is this the only W5100 you have on the network?




No… I have another couple and they work fine. I have also tried this project on a couple of different arduino mega/ethernet w5100 combinations - but the same result. Initial connection, then hang after checking digital inputs/outputs. I have also tried it at two locations (routers) with the same result.
This project uses some virtual pins for input to the dashboard which I haven’t used before but I am unable to remove them to see if they are the problem as I cant maintain a connection.
Thanks for the help,


can we see your code? are you calling a lot of virtual writes by chance?


Aarrgh! A trick for young players! I didn’t realise that the w5100 uses pin 10 and I was trying to use that pin as an output in my code.
All sorted now! Thankyou


yup that will do it! good luck


@bestes maybe we should add something to the comments in the sketch for the W5100 that some pins are reserved for the shield, or gray them out so they cant be used in the dashboard?