Esp8266-12E Program wont run with Cayenne Library

I can program a simple blink sketch on my ESP8266 and it runs fine. When I load my basic Cayenne sketch the program will upload but wont run. I have Arduino IDE 1.8.3. I have tried commenting out but I still get the same result. The only way I can see any serial output is when I have the baud rate set to 74880 when I reset or power on the ESP8266. The output is

ets Jan 8 2013,rst cause:2, boot mode:(3,6)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0xef
csum 0xef
csum err

#define CAYENNE_DEBUG // Uncomment to show debug messages
#define CAYENNE_PRINT Serial // Comment this out to disable prints and save space

#include "CayenneDefines.h"
#include "BlynkSimpleEsp8266.h"
#include "CayenneWiFiClient.h"
#define VIRTUAL_PIN 1

// Cayenne authentication token. This should be obtained from the Cayenne Dashboard.
char token[] = "*****";
// Your network name and password.
char ssid[] = "*******";
char password[] = "*******";

void setup()
  Cayenne.begin(token, ssid, password);

void loop()

Just going off of this thread (though you can find a lot of reasons for similar “rst cause:2, boot mode:(3,6)” type messages if you Google), could you try commenting out the #define CAYENNE_DEBUG part to see if that improves things?

I didn’t say in my original post, but I commented out #define CAYENNE_DEBUG as one of the first troubleshooting steps. I have run into this before but there is so much information on this issue that its difficult to sift through. I was hoping that since I only have this problem when using the Cayenne library that someone would recognize the issue.

Oh…kay… Not sure what happened. Since yesterday I have been having this problem. Then I uploaded ESP8266 Wifi-> WiFi Webserver example, it worked, I played with that for a few seconds turning the LED on/off then re-uploaded the same cayenne sketch as before and it works!.. :unamused:

1 Like

No worries, just glad to hear its behaving. Microcontrollers can be finicky things :slight_smile:

1 Like