How to set up Uno + esp8266 seperate module?

I want to control Neopixel leds by using Cayenne through a Chrome browser on a PC.

I have an Uno board and an Adicore Esp8266-01 wifi module board. I haven’t used the Esp8266 board before.

I have existing code and libraries that define led color animations that I currently run from the Uno. How would I set up my system to utilize Cayenne to provide control inputs to the sketch that controls the leds?


It is possible, however I need to test it better myself. It relies on the ESP having the NodeMCU/AT firmware.



1 Like

Thanks. Would I just choose the WIFI shield sketch in this case? Or would I use the manual sketch? I assume I would wire the Rx and Tx of the module to the Uno.

Busy week for me.

I have a solution that compiles, and want to put together a how-to to use the esp8266 as a shield.

I hope to have time this weekend.




I can confirm that this howto works.

This code is again not yet officially supported by Cayenne, so let me know and the community can help you.

Note, when you upload to the UNO, you will want to disconnect the Arduino RX line otherwise you can’t program the UNO because the ESP and the IDE are both trying to drive the same line.



1 Like

Bumping this old thread to share that we’ve just provided support in our MQTT Arduino library for using ESP8266 as a shield :slight_smile: We’ve done basic testing and works well. Give it a try for your project and let us know how it works out for you !

Here is the updated library on our github:

and the code can be found here:

sir i need help.

Install the library via the Arduino IDE (Sketch->Include Library->Add .ZIP Library) from the Cayenne extras/libraries folder (e.g. My Documents\Arduino\libraries\CayenneMQTT\extras\libraries) to compile this example

i already install

but when i try #include still not such file or directory

are there files present inside the folder?

yup, the CayenneMQTTESP8266Shield.h inside the folder

and still like this

this file inside ESP8266SerialLibrary Folder

sorry sir im new in arduino and cayenne,
in need connect to Cayenne platform for my Final Exam :slight_smile:

Have you tried deleting all Cayenne libraries and reinstalling?

@adam this issue was solved by doing the same thing you suggested but in PM.

1 Like