Need your help peeps




I am using the nodeMCU 0.9 ESP8266.

I have downloaded the CayenneMQTTESP8266 Library

But for some reason my sketch will not recognize (orange text) the library when defined.
I have tried un-installing Arduino, deleting libraries and adding again, I have tried everything except keywords.txt file manually being added because I have no idea where to even start with that [ over my head]

Attatched is a screen shot of my sketch example (untouched) and the LIBRARIES folder currently located in my MAC>Documents>ARDUINO>LIBRARIES



@ham welcome to cayenne community. i use windows and not sure what that error is on your mac.
but did you add “” in your additonal board manager ?


Have you tried compiling it? Sometimes the IDE just won’t highlight it but that doesn’t necessarily mean that it isn’t going to work. If you get errors please post here.

One case where it will never highlight is if you have the IDE open, install a library, then try to use it without completely closing the IDE first.

@rsiegel any ideas why it’s not highlighted orange? I’ll admit that I don’t know a whole lot about the IDE itself.


From my understanding, the #include library lines will only turn orange if there is an appropriately set up keywords.txt as part of the library. This discussion has more about it: I don’t think we ever set that up for our libraries – it shouldn’t have any negative effect on compilation as far as I know.

I do notice in the original screenshot that you’re referencing CayenneMQTTESP6266.h (notice the 6 rather than an 8.) That’s the first place I’d correct if you’re having some trouble actually using the code – may just be a typo. If its still giving you trouble, let us know what the compilation errors are and we can help troubleshoot.


I have been working on a mac for a while, and I have noticed that programming arduino on mac is just plain hard. Try different versions of the IDE and checking the log file in the IDE.