Trigger Troubleshooting

I use ESP8266 with Cayenne MQTT.

I transmit to the Cayenne the data 0 or 1 in 32 channels
Cayenne.virtualWrite(32, ONE);

  1. If I create a new widget, register 32 channels in it and transfer data to it, it does not work. Widget created automatically works correctly.

  2. I want to create a trigger that sends sms if the value 0 is in this channel. But it does not work.

What I’m doing is not right?

You don’t do anything wrong. I am waiting for it to be solved for days: Trigger is not working

But one trigger normaly work.
It is configured for on button in my desktop
Another trigger is configured for incoming data from ESP.
He does`t work

Lately, I carried out some tests to see which part is problematic in triggers. First, I set up schedule to activate a trigger and send me a message and it worked perfectly in time. In addition, I tried trigger with digital “IF condition”(2 state widget as “If”) and it is also working. So, we can infer that the part that actuates triggers are working and the problematic side is TRIGGERS CANNOT DETECT CHANGE IN ANALOG INPUT. It does when “if” condition is digital but not when it is analog. So @bestes , you can narrow down your “bug finding area” and just try to debug that “sensing the analog input” part.

1 Like

@den_box and @nicathesenov How long is the value set to the trigger value? Is it less than one second, a minute, etc? I ask to see if the value is changing too fast for the server to recognize the value has entered the trigger conditions.

@adam, I waited for couple of minutes for trigger to react, not more than that. During this minutes, I ensured that trigger’s true condition is met.

1 Like

Thanks for answers.
I was convinced that the trigger for ANALOG channels really does not work.
But how do I change to digital?
The data is digital, I am transmitting the state 0 or 1.
Cayenne himself perceives them as analogues. And does not allow me to create a widget for this channel with digital data.

In the Dashboard, “Add new…” -> “Device/Widget” -> “2 State” under the Custom Widgets.
Then set Name, choose Device, choose Digital Sensor for Data, choose Digital(0/1) for Unit, type channel number and Add Widget.
Finally, choose this widget as your if condition for your trigger. Good Luck!

If I do this, the widget always displays zero. Although, I know that it is transmitted 1.
If I delete this widget, a new one appears in a few seconds. This is because the 32 channels receive data.
With the new widget, I can only configure the name and shortcut. Incoming data it displays correctly. But the trigger on it does not work.

Maybe it accepts data but not showing it correctly. For me, it was like that. Even if it is not showing it, can you try the triggers with that widget?

Automatic appearing widget is probably analog widget. And it is a known issue that trigger would not work.

Can not do anything and the trigger for this channel will not work?

Can you try with digital 2 state widget even if it is not showing data correctly?

All the same does not work: (((
Added widget to this channel. He always shows 0.
Triggers do not work on it.
I noticed that the online / offline trigger does not work
A trigger triggered on the widget that turns on the light is working fine.

I ran a test with LED output and counter. Counter just counts up while LED is on and counts down while LED is off
I have widgets for both counter and LED control in the dashboard. the counter and LED have the expected behavior when manually controlled (except at startup where LED does not match control but that is a different problem)
I set a trigger to turn the LED on when counter goes below a certain number and another trigger to turn the LED off when the counter goes above a different (higher) number.

Neither of the triggers works.

Has anyone gotten a trigger to work for an analog value?

If not, is there a work-around

My triggers do not work.
The problem began when I started working with ESB8266 and MQTT.
Earlier, when working with arduino UNO was not a problem.

I await a response from the specialists of the cayenne.

Any news here on the trigger issue? I am trying to trigger an ESP8266 based board from a RPi3 - no go - the widgets/ESP8266 responds well when directly activated but do not respond when triggering from the RPi3.

1 Like

No news.
Waiting for a response from engineers of cayenne

@den_box @gregvmail1 @elizabethsimon

Do you have some time for a quick Skype call to go over what you are seeing? It’d be valuable to see the issue produce in real time w/ a screen share.

You can pick any time at your convenience by using my calendly link here: .

@nicathesenov thank you for helping to narrow some of issue down!

Did you make any progress with this? I am having the exact same issue using the Sparkfun ESP8266 Thing Board. I can’t manually create a digital widget that works and the auto generated one is AnalogSensor. The auto generated widget displays correctly but will not generate a trigger.

No, I do not have a trigger.
I’m trying to figure out how to deceive him.
Not yet.