Triggers not working 07/04/2017

Hello there,
I have started using cayenne before a month and this is my first post here in the forum.
I have anticipated a strange behavior in the triggering system.
Before I start explaining my problem i would like to state that I’m using ESP8266-01 GPIO-0 and GPIO-2 to read a DS18B20 for temp input and use a relay as output. I’m using online dashboard via Chrome browser. And I’ve programmed ESP8266 with Arduino’s IDE. Also I am not using ESP8266 with MQTT protocol but as an Arduino connected device via WiFi. My schematics and code works fine since i have temp readings on my dashboard and i can turn on-off my relay. I’ve tried many combinations with the triggers but still it doesn’t seem to work. I turned them on-off,I created only 1 simple trigger (above 40C turn the Relay on), I’ve tried using both Celsius, Fahrenheit combination in my code and in cayenne’s dashboard but it seems nothing has happened.

Any guidance to get through this would be appreciated.
Best regards, Kostas.

There seems to be some issues with triggers right now, so I’m going to say it’s probably nothing wrong with your setup. The Cayenneteam is having a hard time replicating the problems. @rsiegel might have some better info for you.

Hi Kostas,

We’re indeed aware of a handful of users with triggers issues where our in house triggers tests are passing OK. If you’re comfortable with it, we’d like to have a look inside your account so we can reproduce the failure of triggers to run with our QA team. Do you mind sharing your account login/password via private message by clicking on my name on this post? You can change your password using this form to something you are OK with sharing.

If not, I understand. We’ll continue to investigate the issue with other users and I’ll respond to this thread as soon as I know more.

@rsiegel i would like to get in contact with you guys about triggers between 2 devices… Both are Controlino PLC’s (Based on Atmega2560) And i have setup a trigger were a contact sensor is on 1 plc.
When it goes on the other PLC should trigger and set the lights on…

But at the present time i could not get the trigger to fire… I have made a 2nd trigger inside the unit with a status to see if the trigger gets fired… But it never engages…

The triggers is a virtual pin which i set by Cayenne.virtualWrite(V0, 1); So it should be On(1) << Trigger??

On the status page of the unit were the trigger comes from it is activated…

Thansk Daniel

@rsiegel Hello m8, did you find out anything about my triggers ?
Is there any chance
#include "BlynkSimpleEsp8266.h"
affects the trigger system ??

Hi there,

I’m also having problems with my triggers, and they are quite simple, just a temperature above 30ºC in two DS18B20 sensors (using a RaspPi).

I can share privately my password if needed.

Thanks in advance,


It looks like the triggers have started working again for my setup as of this AM!

1 Like

Hi @k.ifantidis, sorry for the delay, I was out of the office earlier this week. We believe the trigger issues were on the server side and have been resolved. I do not think that any include statement in your sketch code would have affected this server-side feature.

We are aware of a more minor issue. If your triggers have a notification attached, it is sending double emails/SMS even though the trigger is only firing once. We’ll try to squash that shortly.

@hallerhoek & @joana.x – can you try your triggers again and let me know if they are now firing properly? If not, I would be interested in your account info if you can Private Message it to me. As before, you can change your password using this form to something you are OK with sharing.

working perfectly :smiley:

1 Like