Trigger Troubleshooting

#31

Ch 5 is my response (then) channel.
I am triggering on Chs 1,2,3.
It appears only the trigger on Ch 2 is working.

Ralph

1 Like
#32

If you have some time, can you check if sending the data over different channels will make the triggers work? Like Ch. 6,7,8,9 for example?

~Benny

#33

I’m currently unable to physically change the channel because my device is installed in the roof cavity (I could make the change next week).
I’ve just only recently changed it from channel 49 where the detection was sometimes spontaneous to now channel 43 where the sensor seems to work 100% of the time. But no trigger activate.

#34

Ok, so it sounds like you already know the answer here.

I tried Ch 6,7,8,9 and they all worked as the trigger source.

One caveat - they only worked with luxWrite. They would not work with virtualWrite.

I would really like “virtualWrite(ch, value, “digital_sensor”, “d”);” to work.

As an experiment I tried “virtualWrite(6, 1, “lum”, “lux”);” which I believe is equivalent to “luxWrite(6, 1);” And only the luxWrite worked as a trigger. Both widget appear identical. So there is something magic about the luxWrite. I haven’t tried the other write variants yet.

And it may be coincidental, but when I added a lot of widgets, the dashboard was very slow to respond. Almost unusable.

Ralph

1 Like
#35

In my case I don’t know if it’s specifically a channel # problem. Because I also have a trigger to fire when my device goes on and offline. These triggers don’t fire either.

#36

Sorry just got a chance to work on this now . . .

Used channel 9

As rjydex, virtualWrite does not work, luxWrite does but . . .only once. After I try to retrigger, it does not work, unless I go to the MyTriggers list and turn it off and then on again, then it works but just once.

Almost there I think.

Greg

1 Like
#37

I hate to say this, but I’m going backwards. I was going to do some workaround code, but Ch 6-9 are no longer working for me with luxWrite. If you haven’t made changes then maybe this isn’t repeatable. It is still working on Ch 2.

Ralph

1 Like
#38

@rjydev @gregvmail1 thank you so much for helping to test this out. Good news is I’ve been able to reproduce the issue on my end, just not consistently. We’re looking into this, and I’ll plan to give everyone an update on this beginning of next week!

~Benny

#39

Thanks Benny and Cayenne developers!

“Update”:
Tryed again this morning, and I am still able to trigger with luxWrite, but only only once unless I “reset” the trigger on the MyTriggers dashboard

1 Like
#40

[RESOLVED]
@bestes test triggers again.
i began with channel 6 not responding => channel 8 working good at this time !!
Waiting 5 seconds and SMS knock at my phone !
Today Triggers and Schedulling working all together … i must change all Channel to use Triggers and it’s ok !?
Huraaahhh :smile:

#41

So today, without changing anything my end I’m happy to report my triggers started working again. Sensor is attached to Channel 43 and always worked but without triggers. Now triggers are SMS and emailing me. Don’t know what happened, must be something you guys have found, because I’ve done nothing.

1 Like
#42

Hooray!
Triggers are working. Without any changes on my part.
Thanks to the developers!
There is one question left:
do not work Online / Offline triggers
This is clearly a developer error. For these triggers, I did not write any code.
Will this bug be fixed?

#43

@den_box @ryates2 @samarchri Hey guys, checking in - how have the triggers been over last days?
~B

#44

Yes working perfectly.

1 Like
#45

Yes working perfectly Benny and I’ve been hitting them pretty hard as I
troubleshoot a sensor my end.

thanks,

Robert.

#46

Hi @bestes
this morning, triggers working very well

#47

@samarchri @ryates2 Thanks for the update guys!

~B

#48

Hello!
My triggers are working.
But triggers do not work online / offline

1 Like
#49

Hi!
Triggers “online” and “offline” do not work.
Help?!?

#50

Hi @den_box, apologies for the trouble. Can I assume that the device you’re having trouble with these triggers on is connected via MQTT? We’re aware of an issue with MQTT device online/offline triggers aren’t firing at this time.

I’ll update as soon as its fixed – until then, if it is an Pi/Arduino/ESP8266 and these online/offline triggers are important for you, the workaround would be to connect via the respective non-MQTT options in the Cayenne UI (ESP8266 can unofficially be connected ‘as an Arduino’ in Cayenne following the steps in this post). The non-MQTT options should have functioning online/offline triggers.