Adding a new widget for MKR1000


#1

I have connected Arduino MKR1000 as Arduino UNO and WIFI 101 shield because MKR1000 is not in the selection boards.

It is not can choose pin from Digital, Analog, Virtual

For other boards everything is working properly
Please help @bestes @kreggly @adam @rsiegel


#2

Adding buttons etc is broken in the browser interface. you can still add
them through the Android app.

Craig.


#3

When I add a new widget on Android so crashes applications.


#4

I had no problems in Android.


#5

I have solved it so that I used MQTT and MKR1000.


#8

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#9

#10

Sweet. Yeah, I know the custom widgets are working. Although mqtt is not enabled with the mobile apps yet.

Cheers,

Craig


#11

Hey guys, sorry for my late response here. We are aware of the issue, it appears limited to MKR1000 devices (although maybe it exists for other boards which aren’t explicitly appearing in the UI as well, the MKR1000 is the only we’ve found thus far).

It’s on our hotlist of bugs to fix so should hopefully be resolved shortly, and I’ll update this thread at that time. In the meantime, glad that you were able to find a workaround until we get it sorted out.


#12

Any new updates on this topic? I’m having issues with the mkr1000 and a Sparkfun SAMD21 dev board doing this yet. I/O is greyed out.