ADS1115 extension not added


#1

Hello,

A couple of years have passed since I was on Cayenne. I was having difficulty adding a ADS1115 analog to digital converter.
I’m taking a different approach to describing the problem since I can’t add the device now.
This is the sequence of events and the result:
I tried to add an ADS1115 to my Rapsberry Pi project.
Add
-Devices&Widgets
–Extensions
—Analog Converter
----ADS1115
-----channel 49

“Please fix the following errors:”
“Please turn on the device”

Needless to say the device is on and running. A datafile is created each morning and readings stored in that data file.

I followed up with:
ADD
-Sensors
–Generic
—ADS1115
----channel 1
-----Gauge
with the same eror message.

What next?


#2

Are you using the Raspberry Pi agent 2.0? Extensions are no longer supported. Raspberry Pi Agent 2.0


#3

As reported by adam, extensions are not supported in agent 2.0. First of all when you try to add a ADS115 you will have no option to select device and thus having no option to add channel and gauge details. So can you share a screenshot of your dashboard while adding ADS1115


#4

Thanks.
Late. Just discovered Cayenne responses in my SPAM box.
Agent? I logon to the website, and my dashboard, and attempt to add an ADS1115.
You’re both in a better position to tell me if I’m using Agent 2.0.
Why are extensions available for the ADS1115 on the website, if they can’t be added?
How do I add an ADS1115?


#5

to check the version: on your dashboard top right corner next to your device name there is cog wheel, click on it to open configure and you will find the pi agent version.


#6

Thanks.
The agent is 2.0.1.255.


#7

can you share a screenshot of the dashboard while adding ADS1115


#8

Screenshot after a search for the ADS1115:


#9

Here’s a screenshot from another approach:


#10

can you change name of any one device to something else. As both device names are same. And also what is the agent version of the other device?


#11

No ADS1115 has been added. In the Extensions drop down, there are two Raspberry Pis listed, but not in the Generic Sensor category. I’ve removed the extraneous Raspberry Pi. I’ll try adding the ADS1115 again.


#12

from the screenshot, you have two devices **Raspberry Pi** which has space between and other one which is greyed out is **RaspberryPi**
While adding the ADS1115 and analog input you are selecting the greyed **RaspberryPI**

`


#13

Right. I’ve removed the second, greyed, old Raspberry Pi.
I cannot add an ADS now. The Sensor/Generic/ADS1115 option is blocked and the use of Extensions is blocked. I can find no other options.


#14

extension are not supported on Raspberry Pi Agent 2.0
if you still want to add ADS1115 you will have to add it manually using https://github.com/myDevicesIoT/Cayenne-MQTT-Python and adding the ADS115 code into it.


#15

Thanks. On my way to github.
Why am I getting Extensions headings on Agent 2.0.1.255 if extensions are not supported? Do different devices or PCs get different Agents?


#16

Are you still having option to connect ADS1115 to your raspberry pi agent 2.0?


#17

Hello,

Thanks. My laptop will be down for a few days. I’ll check then,

Thank you,

Jim Julian

Cogito ergo sum.
René Descartes circa 1685
“I think, therefore, I am.”

Sum ergo cogito.

Google 2004

“So, I’m thinking…”


#18

Hello,

I’ve installed the github MQTT python library. A search for the ADS1115 under ‘Devices’ returns nothing. The ADS1115 seems to have disappeared.

Thank you,

Jim Julian

Cogito ergo sum.
René Descartes circa 1685
“I think, therefore, I am.”

Sum ergo cogito.

Google 2004

“So, I’m thinking…”


#19

Hello,

Needless to say, I’m doing everything from my iPhone till my laptop is ready.

Adam, I use Cayenne to monitor the system when I’m not available.
I use Weaved and remote SSH to make any changes. I’m exploring Cayenne’s potential usefulness to my situation. I’ll keep what you’ve said in mind.

Thank you,

Jim Julian

Cogito ergo sum.
René Descartes circa 1685
“I think, therefore, I am.”

Sum ergo cogito.

Google 2004

“So, I’m thinking…”


#20

when you ssh into your Pi and installed the Cayenne MQTT library, you need to add a new device using BYOT. Once added you need a code for ADS1115 https://learn.adafruit.com/raspberry-pi-analog-to-digital-converters/ads1015-slash-ads1115 to get sensor data from it.
Next you need incoporate rhis sensor code into the cayenne code so that it sends data to the cayenne.