Unable to add PWM output


#1

When I go to add actuator and choose Generic and the PWM output then when i head to select the connectivity option then a red ban icon appears on the place where i had to make a selection.
Why so ?
Please help me. Thanks in advance.
VISHAL


#2

add a custom slider widget.


#3

I am trying that too. But the verh next step when I move to select the device option then pointer again turns to ban icon( pic attached ). Any Idea ?
Although I am able to add digital inputs and outputs.
Please help :pray:


#4

looks like you have not added any device to cayenne dashboard. have a look at this to get started with Adding a New Device using MQTT


#5

Sorry but I’m using Raspberry pi and have successfully added actuators such as LED but unable to add analog I/O


#6

The Pi agent does not support PWM. You will have to add an extension like the PCA9685 first then you can add this widget. You can also use MQTT as @shramiksalgaonkar suggested and do the PWM yourself.


#7

@adam Could you please tell me what to choose ( I am a beginner ) in “choose slave” field while adding PCA9685 ? I get an error that “please recheck your settings…”.


#8

Do you have the PCA9685 connected to the Pi? It’s a physical device you need to connect and set up through Cayenne.


#9

Thanks @adam , I got the point. I thought that it is just like adding as a digital output. Very soon will purchase one and hook to my pi. And any further instructions ?


#10

Nope, that should be it for now.