ADS1115 no volts


I’ve installed an ADS1115 in Cayenne but all four channels read zero, though I’ve tied one to the 3.3vdc supply.
I installed the Adafruit software and successfully ran the test scripts. The same with wiringPi.
The only change I made was to add the device to the /etc/webiopi/config file.

Thank you

Note, I opend up my laptop this morning and the ADS1115 voltages are correct.
I guess time was needed for things to take effect…
Oddly, the Weaved/WebIOPi/Device Monitor page showed the correct voltages briefly, then went to zero. I believe the problems were related. Count this as solved.


Thanks for posting an update!



I spoke too soon. The problem seems eratic the first few minutes but stabilizes at zero outputs. The only difference now, is I’m twenty miles away. Wish I had better news.

I think the initial correct values followed by stability at zero values may indicate the ADS1115 is in ‘One-shot’ mode.
I’m looking through the files on the Pi for a clue as to how to set that option and others, such as sample rate…
Is there a way to alter the parameters of the ADS1115 within Cayenne? I’m thinking WebIOPi may have set up a default set of parameters. The webiopi file may have the answer.


@jimlynnjulian2 and @bestes,
I removed from the helped section because I don’t think everything has been sorted out here.

I’ve tried to replicate your situation with an ADS1015. I understand it’s not the same but I thought it would be close. I added the ADS1015 to a RPi 3b that I had loaded Cayenne on, but wasn’t doing anything else. I then put a TMP36 on AØ and a photoresister on A1. Sadly, every thing worked fine with the 1015. Both sensors are responding appropriately to varying stimulus. The voltage shown on the ADS1015 page are steady and above zero. Below is a photo of the setup and a couple screen captures. The varying graphs are because I was changing the temp and light to the sensors.

Sorry I wasn’t much help, I’ll see if I can track down a proper ADS1115.



Hello Ian,

Thank you for responding.
I agree, the situation was to unstable to consider done.
If you want to try and replicate the situation, there are several things to take into account.
I installed the Adafruit software for the ADS1115 and successfully ran the example scripts :

I think the installation of other gpio manipulation software may be the issue. Along with the Adafruit software, I’ve also installed wiringPi and the WebIOPi/Weaved software and applied the patch mentioned on the Google groups WebIOPi site. Any of those could have modified the Cayenne/Weaved installation.
Since more than one probably has a service running after boot, I will look and remove all gpio related services but Cayenne.


Thank you for being aware of the possible conflicts here. As we are seeing other folks having difficulties with the implementation of ADS1115’s I’m going to get a couple ordered and see if I can replicate the things that are being seen by others.




I’ve run the Adafruit s/w without problems. This tells me there’s a problem in the programming. I would examine WebIOPi’s and the in the containing directory. Those seem to be the files most directly related to the ads1115.

note: the ‘init’ is preceeded and followed by two underscore characters not shown here.


Hello Ian,

I have a couple of questions about the screenshot of yopur dashboard.
What device was used? a laptop, tablet, phone?
There are several RPi’s on the sidebar. Does each represent a different physical Pi?
There is an ads1115 listed on the sidebar. How did ti get there? My ads is listed on the extensions page only. Needless to say, neither of the two projects I created is listed on the sidebar. What exactly does the sidebar represent?

Thank you,
Jim J


Thanks for the note! Lets see if I can fill in some blanks for you.

The screen shot is from my desktop computer.
Windows 10 is the OS
Chrome is the browser

Yes. In that capture I had 4 RPi’s on my account.
1 - RPi 3b
1 - RPi 2b
2 - Zero rev 1

Look closer, it is a ADS1015 not an ADS1115. I did recieve an ADS1115 the other day so that I can do a test run as we have seen several folks having troubles with them.

Added it through the
Add new…> Device/Widget > Extensions > Analog Converter > ADS1015

I’m not sure why this would be happening. The workflow I’ve explained has been my experience since my introduction to Cayenne in February. I cannot speak to anything iOS as I don’t do anything iOS.

It is all the Single Board Computers (Raspberry Pi’s) and MicroControllers (Arduino/ESP8266) I have on my account with all of the sensors, actuators, Extensions, and Virtual pins that are attached to same, all shown in a hierarchy.

Here is a photo of my current dashboard with one Arduino and 2 8266 attached along with the same 4 RPi’s. Note that the overview shown has both a DHT21 and BME280 sensors sowing the corresponding reading from each sensor. Both sensors are on the same breadboard.

I hope this helps, please let me know if you have anymore questions.




Thanks for responding and for the answers to my questions.
There is another question. Your’s is the second screen shot I’ve seen that shows devices attached to the ADS device. I’m using four solar cells. They’re not attached in the dashboard, but are physically attached. How did you make the attachment?



Hi Jim,

You should add the solar cells as widgets to the dashboard. You can do so by adding a new device using the ‘generic analog widget’ and referencing the ADS1115 when adding the widget. I’ve attached an example screenshot.

I think that adding a widget that references the channel where your solar cell is connected to the ADS1115 extension may make it more stable. Let us know what you find?



Thanks for the information. I had an ‘ah-ha’ moment.

Unfortunately, nothing has changed in the readings. I rebooted the app after the change, but readings remain the same.