Ads115 wrong volts



Just wiped my SD card, reformatted and installed a fresh image.
I then installed Apache and related files, PHP5, and MySQL.
I then setup the wifi and installed the changes to make the Pi a wifi access point.
After all this I installed Cayenne.

I then added the ADS1115.
The volts are wrong and fluctuates to a small degree. In short, nothing has changed.

I have a solar detector fixture composed of four small solar cells as input to the ADS1115.

I have not installed the Adafruit software.

In “ADS1115-reporting-0-17-volts”, or similar, a clean wipe solved the problem.
I can suppose, if the hardware is good, that one of the actions preceding the installation of Cayenne, is incompatible.

Any ideas? The obvious is to install Cayenne before anything, except the wifi since I’m running ‘headless’.

I’m fairly sure the Adafruit software will run correctly if I install, but may complicate things further.

If no one has any ideas in the next few days, I’m going to do another installation and make wifi setup the only modification to the pi before installing Cayenne.

Since posting this, I’ve installed Weaved and run the installer. Same readings as Cayenne. No change in Cayenne’s output.


I’ll see if I can reproduce that tonight. It’s about time I actually test this ADS1115 I got.


I have a word. Chagrin.

The ADS1115 in Cayenne has suddenly and ‘magically’ began displaying correct voltages, or rather, the correct decimal fractions of 4.096. We can call that, percent of max scale at gain = 1.
.25 * 4.096 = 1.024vdc.

Another poster has had the same problem. First, a group of fixed numbers, all the same value, all static, followed by an inexplicable transition to the nominal state.

The event is not traceable since I began installing more software. There could be a component common to many packages that causes/corrects the problem.

I’ve also been making minor edits to the python script I use to read the chip.

I’ve been having problems getting Pi to accept a 64gb Sandisk Ultra XC memory card.
The next time I start a session to solve that problem, I’ll wipe the 16gb I’m using and do another ‘scratch’ test.

I no longer need help, or I won’t until the next time?
Count this done.
Jim J.


Sure thing, I’ll mark it as helped. just post back when/if you find anything!


Make sure that if/when you actually test that ads1115 you’ve got, that you post the results.


I did have it hooked up a while back and it was working as I would expect (still not quite sure what to do with it yet) but I didn’t leave it connected. I’ll let it log for a while and see what the results are. I did just notice that there is an error with the order of the values on the extension page: A0=A3, A1=A2, A2=A1, A3=A0. If I create a widget for the individual channels they display fine. I hooked up a photocell with a resistor and it reads 0.03 when the lights are off and 0.2 when the lights are on. I’m not sure what the values “should” be but they are changing with the light intensity.


I spoke too soon, again.

I just booted the system and Cayenne is back to the previous mode of static wrong readouts of about the same value.

Good luck.