Dashboard updates slowly or not at all

Hello everyone.

I’ve got a project with 7 sensors and trying to display them on my dashboard. The thing is, graphs are updating once or twice maybe no matter how long I wait, before I reset the connection. I’m using 115200 baudrate, got 1sec delays between readings so I don’t know why it is that slow. I’m using Arduino Mega with serial usb connection.

Dashboard continues to update “Last data packet sent” time but nothing changes.

Is there anything I can?

Hi @atacan.yucel,

Hmm. Can you try delaying the rate between readings to 5 seconds to see if that helps? Would also be great to know what device you are using and what sensors. Attaching the code you are using would probably help too!



Hi again.

I’m using Arduino Mega with serial usb connection. Tried that with 5 seconds too, didn’t work. I’m using 4 mq sensors, 1 hdc1080, 1 bmp280 and a water sensor. It’s a bit much for arduino so I supply them externally.

Thank you for your help.

Here is the code

Link says not found…

My bad, sorry. Link’s working again.


I have same problem.[quote=“atacan.yucel, post:1, topic:3600”]
Dashboard continues to update “Last data packet sent” time but nothing changes.

I’m using 9600 baudrate. Same question [quote=“atacan.yucel, post:1, topic:3600”]
Is there anything I can?

-MHcode.txt (1,6 Kt)

One thing that comes to mind is that you cant use the serial output to display messages in the serial console. It will interfere with the script that connects to the dashboard.

Hi @adam

If I uderstand correct you mean that remove this #define CAYENNE PRINT Serial ? I tested that and no help. Widgets updates couple minutes but then they freezing or something. Last data packet sent: log still running.


Yes you are right and that’s why I don’t use serial command. It’s commented out, I just use lt when I need debugging.

Ok, just wanted to check that part. Are you getting any messages in the output of your .bat script, errors, etc? Kind of stumped on this one…never heard of an Arduino connecting but then not updating graphs. Is there any possibility you could connect with an ethernet/wifi shield so you can see the output to check for errors there?

@mattiheikkinen84 yes, comment that part out, but I think the problem also occurs when you simply open the serial monitor.

I propably found the problem :sunglasses:. I ran simple D18S20 sensor code with uptime and now it works. Maybe 6 temp sensor, 4 moisture sensors, 2 water level sensor and two relays are too much to the Arduino Uno. Need to add second arduino and test with that combination.

Nope, I not getting any errors. And btw, with just a couple sensors, graphs work just fine. I don’t have a shield right now but currently I’m working on using wifi with esp8266. After that I will update the result.

And yeah, I think it’s a bit weird too, I tried differend arduino’s and pc’s and networks too, so I guess the problem is about serial communication with cayenne. Thank you for the tips.

Did you cut out any one sensor out completely, or just reduce the number overall? Just trying to figure out if it was a particular sensor or if it’s a problem of sending too much data.


I have the same behavior. My sensors are working perfectly from two years but dashboard doesn’t follows the data I have. Actually I got a 0.0 value on the plots even if the readings of the sensors are not zero. In conclusions, the dashboard sometimes works fine, sometimes has a strange behavior.



Some of reason if I add more that 6 sensor to my Uno dashboard icons “freezing”. Now I have 6pce D18s20 sensors and uptime code and everything works fine and other sensors I need to run with second Uno. If I add all to same Uno… code works and send data but dashboard icons don’t update. I don’t know reason but now it works some way and thats ok for me


1 Like

I had more or less the same behavior. My dashboard was frozen for several days to 0.0 value for all sensors. Than I discovered a date and time problem. My Pizero was 40 minutes late with respect to the actual time. After resetting time and date my dashboard works again.

To reset time I did:

sudo service ntp stop
sudo ntpd -gq
sudo service ntp start



That’s an interesting fix. I know they just pushed a fix for the graphs last night, might have just been a coincidence as well.

The fix we did yesterday was specifically for MQTT device data history graphs reading a zero value, even while the parent widget showed a correct and real time value.