Graphs are not working as expected. No data available

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)
    Arduino UNO via Serial USB connection to Windows 10 PC
    Also using MQTT as the Arduino IDE does not give an option to use anything else as shown in the installation docs.

  • What dashboard are you using? (Web, iOS, Android)
    Web on Chrome

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!
    I’m using very little more than the example code to send data from a temperature and pressure sensor to two graphs. Clicking “live” shows the data, but clicking “m” for last 10 minutes give me a no data error. In fact all of the other time scales give errors too apart from “live”
    Even in the data tab historical information is disappearing.

I should add that clicking “m” etc puts the graph x axis from Jan 01 1:00am to Jan 01 1:am for some reason even with custom date ranges.

The data tab is only showing channel 0 no matter what filtering and sorting I do, yet channel 1 and 2 showing on the overview, so there is data there.

I’m in the UK, is the date format an issue?

we had a small server issue yesterday and it has been solved now. Can you give a try now.

Just the same. All sorts of things are broken.
I’m sending 3 data items that show up in Value widget yet wont in graphs. Also, only channel 0 is showing in Data no matter what filter settings are used.

can you share the code you are using?

It’s just the example given with the library with a few lines added to show temp,pressure from a BMP180 and a random value. As mentioned the values seem to appear in “value” widgets, but don’t show in graphs or data.

#include <CayenneMQTTSerial.h>

#include <Wire.h>
#include <Adafruit_BMP085.h>
Adafruit_BMP085 bmp;

// Cayenne authentication info. This should be obtained from the Cayenne Dashboard.
char username[] = "xxxxxxxxxxxxxxxxxxxxxxxx";
char password[] = "xxxxxxxxxxxxxxxxxxxxxxxx";
char clientID[] = "xxxxxxxxxxxxxxxxxxxxxxxx";

void setup()
  //Baud rate can be specified by calling Cayenne.begin(username, password, clientID, 9600);
  Cayenne.begin(username, password, clientID);

  if (!bmp.begin()) {
  Serial.println("Could not find a valid BMP085 sensor, check wiring!");
  while (1) {}

void loop() {

// Default function for sending sensor data at intervals to Cayenne.
// You can also use functions for specific channels, e.g CAYENNE_OUT(1) for sending channel 1 data.
  // Write data to Cayenne here. This example just sends the current uptime in milliseconds on virtual channel 0.
  //Cayenne.virtualWrite(0, 4);
  // Some examples of other functions you can use to send data.
  Cayenne.celsiusWrite(0, bmp.readTemperature());
  Cayenne.pascalWrite(1, bmp.readPressure());
  Cayenne.virtualWrite(2, random(0,100));
  //Cayenne.luxWrite(2, 700);
  //Cayenne.virtualWrite(3, 50, TYPE_PROXIMITY, UNIT_CENTIMETER);

// Default function for processing actuator commands from the Cayenne Dashboard.
// You can also use functions for specific channels, e.g CAYENNE_IN(1) for channel 1 commands.
  //Process message here. If there is an error set an error message using getValue.setError(), e.g getValue.setError("Error message");

can you private message me your account details so i can have a look at your dashboard. you can change your password here

First delete all the three charts from your dashboard. Make the following changes in your code and upload it. Once uploaded you dashboard will automatically populate with three more widget with name as channel 3, 4 and 5.


  Cayenne.celsiusWrite(0, bmp.readTemperature());
  Cayenne.pascalWrite(1, bmp.readPressure());
  Cayenne.virtualWrite(2, random(0,100));
Cayenne.virtualWrite(3, bmp.readTemperature(), "temp", "c");
Cayenne.virtualWrite(4, bmp.readPressure(); "bp", "pa");
Cayenne.virtualWrite(5, random(0,100), "analog_sensor", "null");

Add the three widgets to your dashboard by clicking on + on the top right corner of each green temporary widgets.
Once added to your dashboard click on the cogwheel icon on the top right corner of widget and select setting. Change the choose widget option from value to line chart.

Your suggestion seemed to work initially, but it’s stopped working again so I retracted my latest post after I do further testing.

you will need to add a new device to your dashboard and start all over again. Dont use reset dashboard.

I just did this. I killed all existing devices and recreated a new one. Everything seemed to work for a few minutes and then stopped. The Data table seems to still be updating for all channels though, but none of the widgets are for large periods of time.

I wonder if this coincided with the time I renamed the widgets from thier default Channel x names to something else?

it seems to be working fine on your account at my end.

Yes it just started updating again in the last half a minute. But it didn’t update for almost 10 minutes. Then there’s seems to be an inrush of updates.

i will monitor your device for sometime and see if it happens again.
you can also keep an eye for the same and let me know if it occurs again.

1 Like

It’s just stopped again (graphs) even though the update at the bottom of the window is up to date. FYI I removed the random data virtual data as it’s no longer needed about 10 m ago.

…and a few minutes later it’s working again…
… live view is completely static…
…live view working again a few minutes later…

your live temperature graph is static because there is no change and thus it produce a straight line. when this error occur are you making any changes to your device? also changing from live to minutes to hour solves this issue?

You’d get a perfectly horizontal line for unchanging data values. My issue is that I’m getting a point not a line, signifying no updating at all.
Here’s an example of unchanging data values, but it is indeed updating

There’s also the error “no data” too in the image above in the previous post of mine

Even then the pressure sensor has different data on each data point yet live was static and “m” was also saying “no data”

Again, it seems to fix itself after 10 minutes, then breaks. As of this exact second it seems to be working again. I’ll post again when it breaks.

you see that point because the live data does not show previous data and start from that time instant and will update every 15 seconds as it receives more data. i am also monitoring your account but cant track the issue of no data.

It stayed as a point for a good 5 minutes though.

Also, in my previous screenshot you can see in “m” mode I got the “no data” error again when I’ve been uploading data for a few hours now.

when that occurs try shifting from m to h to d and see if the issue occurs.

That was the first thing I tried, then a browser refresh too. Several times and for both issues.