Error Compiling

I am using Arduino and Ethernet Shiled W5100 to connect with Cayenne.But when i am compiling my code i am getting error…Suggest suitable solution for my problem

Error message which i am getting in my code…

Arduino: 1.6.5 (Windows 7), Board: “Arduino/Genuino Uno”

In file included from C:\Users\VK\Documents\Arduino\libraries\Cayenne/CayenneEthernet.h:24:0,
from EthernetShieldW5100.ino:21:
C:\Users\VK\Documents\Arduino\libraries\Cayenne/BlynkSimpleEthernet.h:18:22: fatal error: Ethernet.h: No such file or directory
#include <Ethernet.h>
compilation terminated.
Error compiling.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.
I had to add the following lines to get the example sketch to compile on my arduino mega 2560 r3.

#include <SPI.h>
#include <Ethernet.h>

I placed them directly below

#include <CayenneEthernet.h>

Once I did that, I was able to compile the sketch, load it and connect to my dashboard. I am by no means an expert. All I can tell you is that it worked for me. Hope you have success.


still getting error…give me sollution…

You have not followed the directions I gave you. Read my reply again, follow what I have told you to do and it should work.If you look at the error you are getting, it clearly shows what you need to add- which you have not done. If you look at the information I provided, I gave you both lines that you need to add and told you where to put them in your sketch. You have not done any of this. So, it appears that you are using the exact same sketch that gave you problems in the first place and expecting different results. :smirk:

I see you are on version 1.6.5 of the Arduino IDE. Try updating to 1.6.12 and also updating all libraries and boards.

I was having the same issue that and after add these lines it worked just fine for me! tks

1 Like

Glad to hear @jeffersonluiscell. Thanks for letting us know!

I notice that there is no link on Arduino “about” pulldown to update the Arduino IDE. I’m guessing- just download/install the latest version?

I currently have 1.6.10, later versions are available- so…I’m updating now…to 1.8.0

Yes, you just download and install the new version. It will force you to uninstall the old version first.

1 Like

All you need to do is to install the latest Arduio IDE version.