iPhone-PC-Pi coordination


I’m new to Raspberry Pi and Cayenne as well. I’ve installed Cayene and get the dashboard on my Pi, but nothing on the webpage on my PC (Windows 10 Pro). I want to control a relay board made for the Pi but am having trouble.
I tried to create a Relay device from the iPhone but the thing goes into busy mode, gear/wheel turning, and never comes out.
I select the button widget, the Temp icon, Integrated GPIO, Channel 3, and Inverse Logic. I’ve tried other combinations, read the tutorial, nothing works. I worked as an electronic engineering technician, so I’ve got the electronics down.
While the gauges on the phone read specific non-zero values, the webpage gauges all read zero.
Am I missing something?

Thank you,
Jim Julian

There are still some bugs with the mobile apps lets stick with the web based dashboard for now. Can you post a screen shot of your web based dashboard? Also, make sure all your pop up blockers are off or add Cayenne as an exclusion.

I hope this displays well.

Perhaps I should mention, I’m working headless, using Mobaxterm or putty almost all the time. I’m using Raspbian also. The relay board is pretty common and uses the Songle relays and come in 2,4,8,16 relay models. I’ve set the wiring up to use WebIOPi and Weaved packages as opposed to pi-blaster.


I just followed the same steps on the webpage on my PC that I tried on my iPhone and the same result occurred; unending busy signal.

Looks like it’s offline. Does your Pi have a route to the internet? Do a ping google.com. You can also check the status of the services with “service myDevices status” “service webiopi status”


Thanks for responding.
I tried the shutdown and reboot commands and they failed. I got suspicious. I’ve had a lot of problems with having to rewrite the resolv.conf file to replace a local IP number with the OpenDNS IP number. Once I did that, the desktop version started working. The edits I make to the resolv.conf will not remain permanent.
Where the meters on iPhone are multicolored, the meters on the web are green, but do show values.
I created a relay but the dashboard icon has a “unreachable” message under it.

I’m guessing, but does an ssh client have to be running to use the dashboard?

pi@raspberrypi:~ $ service mydevices status
● mydevices.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)
pi@raspberrypi:~ $

I tried the remote desktop and that works.

your resolv.conf settings would have been the problem. If your Pi can’t resolve the DNS of the Cayenne servers it won’t connect. SSH is not requited for the dashboard, only for install. So is everything working now?


Everything but the message on the relay, “Unreachable”,

I just tried the phone app again and that seems to work too.
The relay control is functional but does nothing to the relay board.
I’m wondering if I’m using a different wiring pattern than is built in to Cayenne.

I attempted to delete the network speed widget on the phone and that seems hung up.
Still, I’m happy with what we’ve accomplished. Thank you ats1080s.

1 Like

There are some issues with network speed. see Bug Filed on 05-06-2016: Network Speed and Processes not loading

For the relay, which GPIO are you using? How do you have it hooked up? Take some pictures or draw up a diagram.

I’m using those pins marked as green. I tried #3 on the phone and #5 on t=
he pc browser. Those are Cayenne numbers.

I’m assuming you’re talking about pin # on that picture? If so use # 11 and try again. 3 and 5 are reserved.


Than k you for responding.
I’ve spent the morning working with the relay board, Pi, Cayenne and the webpage and iPhone user pages.
I have everything working now.
I ran into a few problems, but was able to solve those related to achieving my goals.
What follows are the results of my work which, I hope, will prove useful.
Thank you ats1080s,
Jim Julian

Ceyenne pin numbering issues:
webpage selection range:
iPhone selection range:
working pin numbers entered from iPhone:
Mismatched pin numbers between webpage relay selector and phone selector make duplication impossible.
Not all data entered from phone goes to webpage, obviously.
The icons chosen from the phone have to be set again on the webpage.
Seems slow to process commands under certain conditions.
Two of the relays inherited from the phone had “Unreachable” icons. I think the pin selection mismatch between the webpage and phone selector lists may be at fault.
As for speed, the busy signal in the browser last between 1 and 12 seconds, typically 5 seconds.
The phone is much faster.
I just looked at the GPIO page, as opposed to the Overview page, on the website, and pin 27, is not listed.

I finished making the corresponding changes to the webpage setup to make the phone and webpage the same. If I refresh the webpage and reboot the phone app, both work. If there are bugs I would suggest a closer correspondence between the webpage and iPhone softwares.

The phone apps work locally whereas the browser sends the commands from the Cayenne cloud server, which is where the delay comes from. I’ve never heard anything about pin mismatches before, but I don’t have an iOS device to test with. So you’re saying the pins you can select for the digital output widget are different on the web page dashboard and the iPhone app?