Led light switch button unreachable


#1

Hi, I’m doing some basic tests on my Pi 3 with Cayenne web but every time i connect a LED as an actuator it says unreachable. i have followed cayenne’s video instruction yet i still get the same ‘unreachable’ error. what could be the problem?


#2

This sounds like your Pi might be running the 4.9 Linux kernel, with which webiopi (a component of the Cayenne Pi agent software) is currently incompatible. Could you run the command uname -a to check your kernel version?

If it is showing 4.9, you can switch to the 4.4 kernel with just one command (and a reboot afterwards):
sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

We have an update to the Pi agent in our QA now which should resolve this issue and allow Cayenne to work on both 4.4 and 4.9 in the near future.

If uname -a shows you are already running 4.4, let me know and I’ll continue to help troubleshoot.


#3

ok so i checked and discovered that i was on 4.9 kernel, followed your
command and downgraded to 4.4, still no sensor is working.
i tried motion and led so far.


#4

Have you tried deleting the old widget and setting it up again? That worked for me.


#5

I have done that over and over sensors do not seem to be communicating with
widgets


#6

Do they still read ‘unreachable’? Or just don’t seem to be updating as you’ve expected?


#7

still unreachable


#8

it worked after i changed it the gpio pin from 17 to 26…


#9

Interesting. And presumably it breaks again if you switch back to Pin 17? I know occasionally there are some special reserved pins on these devices, but I’m not aware of anything here. Glad it’s at least working somewhere for you. Are the majority of pins working if you bounce around the options available a bit?


#10

After double checking all the pins i find that every gpio pin works with
led.(i probably had partial contact). G04 however was untested because
there’s no channel 4 on the dashboard. Otherwise everything concerning led
works for me now.
I appreciate the quick help.


#11

No worries, glad to hear things are behaving now. You know where to find us if you need further help :slight_smile:

Would love to see what you’ve got cooking in mind for Cayenne if you want to make a thread about your project in the future!


#12

So my project is 80% complete and am sure it could win a prize if i entered a contest but i hit a snag because i have 2 serial devices on the board (16x2 LCD and BCM180) Since cayenne doesn’t yet support the lcd, i made a custom script to drive it. but when i connect the bcm180, the lcd wont work until i disconnect the bcm180. (both modules share the SDA1 and SCL1 pins). Is there a special way i should connect multiple serial devices to get them to work together?


#13

I’m actually surprised it doesn’t work. You should be able to connect any number of non-conflicting devices to I2C and read them by address. This will complicate your project a bit, but the only way I can see around it is to use the MQTT API. This way you have full control of what happens.


#14

@aotrakstar

I just wanted to bump this thread to note that we’ve now updated our Pi agent to support the 4.9 kernel (it still supports 4.4 as well). The update was automatic in the background so there is nothing you need to do on your end. Feel free to use rpi-update to move forward to the 4.9 kernel at this point if you’d like!


#15

Oh yes. I’m already on the 4.9 update.
Thanks bestest. Runs smooth now. No issues except for the frequent server
error and disconnects from the Android app which forces me to strictly use
the web dashboard for control. :frowning:
Any hope that too will soon be resolved as well?


#16

We just had a meeting about it a couple days ago with our engineering manager and he’s going to be investigating a fix, so there is fresh hope here. If it’s a server side change (what we currently expect) that doesn’t require a new Android app build then it may be fixed very soon. If it requires an Android app update we’ll still do it of course, but it may be a bit longer.