Missing lib


I’m getting the following in the myDevices.log:

Initialize error: /etc/myDevices/libs/libDiscovery.so: cannot open shared object file: No such file or directory

I have looked and sure enough, there’s no file by that name. I’ve searched through the install packages and reinstalled a few times (I’ve not done a full system reinstall, just this package) and nothing.

Any idea where this lib is supposed to come from?

Also, I get the following repeated over and over in the log

2016-12-02 13:59:46 - myDevices - ERROR - Exception on pid:2
Traceback (most recent call last):
File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.20741-py3.4.egg/myDevices/os/services.py”, line 83, in Run
processInfo.Exe = p.exe
File “/usr/local/lib/python3.4/dist-packages/psutil-0.5.0-py3.4-linux-armv7l.egg/psutil/_common.py”, line 75, in get
res = instance.dict[self.func.name] = self.func(instance)
File “/usr/local/lib/python3.4/dist-packages/psutil-0.5.0-py3.4-linux-armv7l.egg/psutil/init.py”, line 227, in exe
exe = self._platform_impl.get_process_exe()
File “/usr/local/lib/python3.4/dist-packages/psutil-0.5.0-py3.4-linux-armv7l.egg/psutil/_pslinux.py”, line 383, in get_process_exe
raise AccessDenied(self.pid, self._process_name)
psutil.error.AccessDenied: (pid=2, name=‘kthreadd’)

Any ideas before I reimage the whole thing (again!) ?


Hi @jason

I don’t think it’s necessary to re-image your pi here. Not just yet, anyway.

The first error I see as well, I’ll double check with the developers but I suspect these might be benign errors where we’re still making some call that we depricated but didn’t clean up after.

Can I ask what (if any) outward problems you’re having with Cayenne that set you in search of this log file? Or just curious about the log messages themselves?


I was looking into why the scheduled events are not working. They went an hour ahead when DST switched, so I tried removing the events and re-adding them, then none of them worked, so I was looking for more info.

These errors are not benign as they completely filled up the log file and I ran out of “disk” space causing a lot of this to break (By the way, why don’t you set up log rotation? Is there really a need for multi-gig log files?) In addition to the logs filling up, the mydevices processes don’t start when they hit this exception, that’s why the logs fill up, they keep trying to start and failing.


Something I’m finding interesting here. The problem seems to have stopped, and somehow, the day after I posted this, my log file was zipped up into a tar file. Now, I didn’t do this, and it hasn’t been an automatic thing that I’ve ever seen, so I need to ask, how much access do you have to our devices? Are you able to log in at will with root permissions?


Hi @jason,

You’re now the 2nd person I’ve seen recently mention a multi-gig log file. Totally agreed that that is not benign, I just wanted to see what if any trouble you were having with the platform. That’s enough trouble in itself on a Raspberry Pi even if its not causing outward issues with Cayenne.

So we do have log rotation implemented (though I concede it must not be working properly in your case if you’re seeing what you’ve mentioned), the limits are 7 days OR 100MB. You’ve already mentioned that yours is way past 100MB, can I ask if it’s also storing log entries from more than 7 days ago too?

No, we don’t have the ability to log into your Pi at will and I’m sure no one from Cayenne has done that. I’ve confirmed with our development team that the archiving of old logs is expected as part of the rotation process, so it sounds like it finally kicked in on your system but should have happened much sooner before things got out of hand.

Our developer that I’ve been talking with has asked if you could share the log file in question, as well as your AppSettings.ini file from /etc/myDevices so we can make an attempt to see what may have went wrong here. Hopefully being a lot of repetitive text the log file compresses into a more manageable size, but let me know if you need some option like a Dropbox or Google Drive account to share a large file with – I’d be happy to set one up for you.


He’s also looking for your Pi model, and your OS version (which you can pull from the command cat /etc/os-release


I had to dump the log that had grown to 4gb in order to get some function back to my PI. The current one is 33M, if you have a dropbox or ftp site, I’ll be happy to send it.


Running a PI2

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION=“8 (jessie)”


I made a Dropbox account that you can log into to upload any files, I’ll PM you the current credentials for it.