Pi 3/Raspbian Stretch install failure

Installing myDevices on a Pi3 running Raspbian Stretch. I have installed on other devices with the same configuration with no errors.

Output of the installer ends with:

Installed /usr/local/lib/python3.5/dist-packages/myDevices-2.0.3-py3.5.egg
Processing dependencies for myDevices==2.0.3
Searching for psutil>=0.7.0
Reading https://pypi.org/simple/psutil/
Downloading https://files.pythonhosted.org/packages/2f/b8/11ec5006d2ec2998cb68349b8d1317c24c284cf918ecd6729739388e4c56/psutil-5.6.1.tar.gz#sha256=fa0a570e0a30b9dd618bffbece590ae15726b47f9f1eaf7518dfb35f4d7dcd21
Best match: psutil 5.6.1
Processing psutil-5.6.1.tar.gz
Writing /tmp/easy_install-8otdsl8j/psutil-5.6.1/setup.cfg
Running psutil-5.6.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-8otdsl8j/psutil-5.6.1/egg-dist-tmp-qj_aspsm
Sun Mar 17 09:50:08 CDT 2019 Build for Python 3.5.3 failed

/var/log/myDevicesSetup ends with the following:

  • normalEcho ‘Trying to install myDevices for python3 version: Python 3.5.3’
    ++ date
  • echo ‘Sun Mar 17 09:49:10 CDT 2019 Trying to install myDevices for python3 version: Python 3.5.3’
  • python3 setup.py install --force --record /etc/myDevices/uninstall/installed_agent
    zip_safe flag not set; analyzing archive contents…
    myDevices.utils.pycache.logger.cpython-35: module MAY be using inspect.getouterframes
    arm-linux-gnueabihf-gcc: internal compiler error: Segmentation fault (program collect2)
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <file:///usr/share/doc/gcc-6/README.Bugs> for instructions.
    error: Setup script exited with error: command ‘arm-linux-gnueabihf-gcc’ failed with exit status 4
  • ‘[’ 1 -ne 0 ‘]’
  • normalEcho ‘Build for Python 3.5.3 failed’
    ++ date
  • echo ‘Sun Mar 17 09:50:08 CDT 2019 Build for Python 3.5.3 failed’
  • exit 1

It’s a fairly recent install of the OS, but I will update and try again. I have not opened a bug report on gcc just yet. Thought I would pursue this route first.

Any ideas?

Thanks,

-Brian

the easiest option is to get the latest raspbian and start with fresh.
if you want to try to resolve it with the current setup, there are a couple of steps user have tried that worked for them, you can try some command and see if it works:

  1. sudo apt-get install python3-pip and try adding the agent.

  2. sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    sudo apt-get install python3.4
    sudo apt-get -f install