Missing serial USB library

Hi all,

I tried to connect my arduino mega via USB to Cayenne (currently problems with my ESP8266). So far so good. BUT: the library “CayenneMQTTSerial.h” from the example sketch is not found. I looked at the downloaded library (all three versions) but it is not included.

I found a hint to try “CayenneSerial.h” but with this I got the error message “error: ‘class CayenneSerialClient’ has no member named ‘loop’”.

Why I get an example from the web site which is not working? And where I will get the missing library from? Google is not helpful in this case.

Thanks a lot for helping me to get in contact with Cayenne.

It sounds like you might be using the old Cayenne library. That has been deprecated in favor of the Cayenne MQTT library. That can be installed via the Arduino Library Manager. Just make sure you install the one called “CayenneMQTT”.

With that installed you should be able to use the example sketch. It should use the “CayenneMQTTSerial.h” header file, not “CayenneSerial.h”.

Hi @Dali9999,

Here’s what the library looks like. Double check that you have it installed in the Library Manager:



many thanks. I only downloaded the library “Cayenne”. Now I could complie the sketch.

But something is still not working. I will not get the connection to Cayenne. Batch file is running with the correct COM-Port. But I have only a loop message and no connect (Waiting for board to connect… ) in the Internet Explorer.


Are you using the cayenne-ser.bat file from the old Cayenne library folder? If so, try using the one under the CayenneMQTT folder: C:\Users\[YourUserName]\Documents\Arduino\libraries\CayenneMQTT\extras\scripts.

Hi jburhenn,

yes it was the right one. I found another hint to delete all other libraries which I do not use for my project. And now it works.

Thanks for helping me.

You’re welcome. Glad that’s working for you now.