Multi line graphs


Hi, I’m very excited about the new feature of the mult line graphs, but unfortunatelly it makes me some trouble using them. I’ve tried for several times to create such a graph but ended up with a number of zombie widgets which I cannot edit anymore. Adding data points to an exsisitng line graph works fine but when I try to edit its features and save the changes, the graph disappears from the dashbord, but on the left hand side list of widgets, it’s still there. The problem is that there is no possibility to neither change nor delete the widget from the list. How can I handle this?


Hi @jungi77,

Would you be able to private message me your account credentials with me so I can login and see what’s happening?




I have exactly the same issue - along with many similar issues…

Hi Same problem here, I have lost so many hours, and projects have started to be neglected. I have many issues that I feel may all be linked to this. Surely this is a bug, it is sooo frustrating that there is not more information available, I have been using Cayenne for around 6 months I had similar issues when I first used Cayenne, and again recently in the past few weeks (Since Arduino updated to MQTT), here is what I have found so far:
Many times you add a new channel to dashboard directly from what is auto detected by cayenne, at this point often you do not get the option to choose any other widget than value widget, at this point you might as well quit and start again - I read somewhere you should always use the first cayenne channel initiated widget to create the graph, then create any other widgets manually, however as option often doesn’t present itself…this is not possible.
This has happened on data types ‘Analog’, ‘Temperature’ and ‘Humidity, maybe more but for me this is what I have experienced.
I have also noticed that when setting data type at arduino to analog and then selecting this as data type on cayenne widget the widget disappears!
Many times when you delete widgets, they remain in the left Navigation tree for the device - impossible to delete!
I also have some widgets that display graphs but the timescales are wrong (Stuck at period in the past) the ‘no data for this period’ seems to be related to the graph updating its date period and the dates displayed are always wrong.
Some widget also will not allow you to get historical data from the chart pop up either (I assume similar issue)
I have done F5 etc so not an issue with cache etc.
Because I can only get part of maybe 30 widgets working I have not reset up any of my triggers and reluctant to do so at this point. I wanted to expand this out but it is just so frustrating, I have added and then deleted maybe 200 widgets 


Hi @paulminize,

Can you post the code you are using?

Also, think you can share your account details (login + password) so I can see some of the issues you’ve brought up. You can change your password here if you’d like.



Hi, Gotta admit pretty new to forums so share details? Publicly? Or is there a private option?

I’ll post some code shortly, new to Arduino so code certainly not good looking :wink:

Cheers for getting back to me, nice product by the way :+1:


Another issue with Multi line graphs :
i got a power widget generated by

Cayenne.virtualWrite(31, powerOutFloat, "pow", "w");

i transform it to Graph .
When i try to add other data like Volt, on this Graph, it simply desapear !!!

I could not do anything : couldn’t delete, couldn’t add to a project. I’m blocked ! Only one thing working: reset dashboard and it get back !


Yes I can confirm i have had a similar experience with dual data point charts, they can disappear when trying to create them, I did get one to work at some point but many more failed and I stopped trying due to fear of losing the working charts I had :sweat_smile:

I imagine when adding a new point to an existing chart, if the new channel data is missing/corrupt it stops the chart being created and hence it demise.


I also have many widgets in the navigation tree that are no loner on my dashboard, the failure for them to clear I think may be linked to then not being able to recreate a new chart?


try to reset dashboard to delete unused widget :


Hi thanks for the tip, it didn’t work as expected BUT I think it may still have solved all my issues - When resetting the dashboard, the widgets didn’t clear, but they returned :slight_smile: - this then shows exactly what I expected many duplicates and with at least one of each channel fully working.

I think…

For now :+1:


See this image - all of the widgets labeled moisture, or channel 4 are same channel, many of these were missing, after resetting they returned so I can delete non-working ones.

I wonder if we can only have one source of chart for each channel, so once one is created and lost, it then stops a new ones being created?



Helps if I attach the image!


like you , i use same chanel for multi widget : Graph + gauge + Value and normaly all working together.
But sometimes "no data for this period "appear …
… while we could see datas of this channel on the Data Console.



I’ve been having similar problems. It seems like the more you change things the more corrupted it gets. Bringing it in as a new BYOT cleared up all kinds of problems. Scheduling and triggers are even working again. Are you using the same virtual channel for different widgets? I’ve been adding additional channels for each widget in the sketch.


Yes I have this too.


I agree, the more you meddle the worse it gets, but also the more time it owes you !!!

I’m using the same channel for value and chart, I read somewhere that you had to add the chart first using the auto populated widget, then you could add the other widget types manually, when this has been an option it seems to work. (Not sure on truth behind this / if it is rumor or true even maybe a bug maybe if it is designed this way?)

Maybe adding extra V channels is the workaround for now…

I’m just going through some checks now but what SuperNinja said somewhere (Maybe another post) seems to have helped massively- use the reset dashboard option this at least seems to bring back any missing widget and allows you to delete, this may help getting back on track - I’m just about to look now.


So I can confirm that resetting the dashboard, does allow all missing widgets to return (Many as full working charts!) you can then keep/delete them. So it seems it has sorted out huge part of the problem, BUT…

Here are my new charts, screen shot was taken at 11:50 UK time, all three charts have different time ranges on them…


Have you tried clicking on the end of each line to see if they are actually being updated at the same time. Maybe just the info at the bottom is off a bit.


Hi I have checked but the dates are all different and do match the labels on the bottom.

So not only are they all wrong, each chart is also differently wrong :face_with_raised_eyebrow:


As i said before , i found that : when you open Data Console , sometimes , you can see your channel is missing in the list . So the graph couldn’t upload new data and stay on last good received values = the time is shifted !
I advise you not to transmit data interval < 5secondes