Removal of the Cayenne application from the Raspberry

I removed my device from the online dashboard. How do you remove the application from the raspberry pi itself?

Is there a command you run, and then possibly a script you edit to remove it from starting?

Any help would be appreciated as I am trying to get the raspberry back to a non 100% utilization state. Thanks.

  • Damon

Everything i have tried I still have a /usr/bin/python3 processes eating all of the CPU.

I tried sudo apt-get remove python3, but that did not fix the issue. The Cayenne software is still starting up apparently.

We are working on an Uninstall process right now. Sorry about this.

As a work around, here are the commands that should do it.


I appreciate your help, but there are no commands included here. I will just push through it manually. If I get time I am going to go through the .sh script and see what was done to install. I can reverse it out after that. This is disappointing. Hopefully they create a un-install script that we can download and run.

Oh, the link had this in it.

systemctl disable myDevices
rm -rf /etc/systemd/system/myDevices.service
rm -rf /etc/init.d/myDevices
rm -rf /usr/bin/myDevices
rm -rf /etc/myDevices/

Cool. Thanks for the command Bestes. I didn’t notice that was a link. Hopefully this will get me closer. Take care.

  • Damon
1 Like

This will not remove WebIOPi which is also installed!

I tried
systemctl disable myDevices
rm -rf /etc/systemd/system/myDevices.service
rm -rf /etc/init.d/myDevices
rm -rf /usr/bin/myDevices
rm -rf /etc/myDevices/

and also disabled/removed WebIOPi but the installation is not back to what it was before.

You can see on my RPI-Monitor statistic that I installed @~20:30 Cayenne, The high peak close to 23h was a re-boot.

In general you see on the graph that Cayenne uses a lot of CPU. The time before was my Jessi running “only”:
Node-RED, MQTT, haproxy, RPI-Monitor, lighttp with PHP5, Samba, VNC, … using 1-3% of CPU time, Cayenne it goes up to 12-15% without having any input/output logic!

You see also on temperature chart that normally the Raspi was in the 40° range and jumped to 50s with Cayenn.

After removal of SW as above I cannot reach previous levels anymore, so something else than in myDevices and WebIOPi must still utilize CPU!

What is this? How can we completely remove Cayenne?

I identified one root cause of the increased CPU/power usage: w1_bus_master1 process.
It seems that Cayenne was/is enabling it.

How can it be disabled? I have nothing to connect and does not want to use it!

Check your cron jobs to see if there is anything in there sudo crontab -e I’m not sure where the w1_bus_master1 is being started. Maybe @eptak can chime in?

1-Wire need to be disabled from /boot/config.txt

before trying to remove manually Cayenne:

  • sudo service cron stop
  • sudo service myDevices stop
  • sudo service webiopi stop
  • removes files (Cayenne and WebIOPi)
  • edit cron
  • sudo service cron start

Cayenne next release will include an uninstaller feature to remove all files and settings when you remove the device from the dashboard.

Thanks, got rid of 1wire after changing boot.txt and reboot.

CPU load and tepmperature seem to be back to normal levels,

p.s.: I really would love Cayenne but only the interface to be run directly from the Raspi, not via cloud services or so.
I also don’t need the direct integration of HW, just access to standard (REST) API’s or services like MQTT.
Cloud service or mobile services can be attached as well but any IOT will be 99% used locally and I would not like that I need to send all data out (to the net) before I can use it!

It’s not really a solution for you…but the iOS and Android apps do run locally. It would be nice to get a windows 10 app that would do the same. Since web browsers are limited for security there isn’t really any way to have a browser interact locally with the pi using their cloud servers.

For anyone who wants to enable/disable 1-wire modules (or other common modules) on raspberrypi, I wrote a simple gui based shell script. See it it helps:

To stop the myDesktop service, do this steps:
1º Disable the services in systemd
systemctl disable myDevices.service
systemctl disable webiopi.service

2º Remove the register in cron
with root user, type: crontab -e
and delete the line of the schedule myDesktop…