RPi Jessie IMG install issue

  • Device & model you are using: Pi 3

  • What dashboard are you using? Web, iOS

I am new to Pi, so not sure if I’m missing a step here or something, however I’ve got the Jessie image file from the RPi website, burn it to a 16Gb SD with Etcher, pop it in the RPi and boot it up. It expands the filesystem, does it’s magic and then puts me on the desktop. I normally go into Configure and set it to allow SSH and activate all the GPIO, etc. It reboots and then I use my iPhone to install Cayenne. The install goes through and I get the dashboard, however when I go to the GPIO screen everything is greyed out and when I try to add a widget it adds it but does nothing. It’s like it has not got access to GPIO? I also can’t change those config toggles in the app to activate I2C, etc.

Any ideas?


Is your raspberry pi online? What about network ports? what about 8181 ?


Yes, online - I can SSH to it fine, I can VNC using the Cayenne app, etc.

HI @craig.savage, welcome to the Cayenne Community.

I’m pretty sure I know what this is.

Run uname -a to check your Pi’s kernel version. Right now we only support the 4.4 Kernel that is part of stock Raspbian Jessie. I bet you are running the 4.9 kernel which has a lot of issues with webiopi, which is a component of Cayenne.

We’re planning to update webiopi to work with 4.9 by the time Raspbian moves to that version. In the meantime, if you have no specific need for the 4.9 kernel on your Pi, you can downgrade to 4.4 by running this command (it will require a reboot after it runs)

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

1 Like

Spot on, fixed it! Many thanks :slight_smile:


Think this could be my problem i ran update on new jessie install hmm… im a give this a shot because i cant even get it to install


You can check very quickly to see if you’re having this issue by running uname -a to see if you’re running the 4.9 Linux Kernel. Post the output here if you’re not sure how to read it.

If your install problem is what you posted in the other thread, I think you’re just missing the invite code part of your installer (unless you edited it out for the forum). If you don’t still have that, remember that you can always generate a new one by logging into your web dashboard at cayenne.mydevices.com and choosing Add New > Device / Widget > Single Board Computers > Raspberry Pi

Tried the later to generate code but the login just takes me to the download app screen???

It will do that if you’re on a phone, or if the browser is too small for the web dashboard. If you are on a computer, try maximizing your browser. If you only have a phone, I’d be happy to login to your account and grab the commands for you from the web dashboard and send them in a private message, if you private message me your account login

root@FishPi:~# wget https://cayenne.mydevices.com/dl/rpi_6wtsmh5sec.sh
–2017-05-10 19:19:17-- https://cayenne.mydevices.com/dl/rpi_6wtsmh5sec.sh
Resolving cayenne.mydevices.com (cayenne.mydevices.com)…,
Connecting to cayenne.mydevices.com (cayenne.mydevices.com)||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1294 (1.3K) [application/x-sh]
Saving to: ‘rpi_6wtsmh5sec.sh.1’

rpi_6wtsmh5sec.sh.1 100%[=====================>] 1.26K --.-KB/s in 0s

2017-05-10 19:19:18 (10.2 MB/s) - ‘rpi_6wtsmh5sec.sh.1’ saved [1294/1294]


root@FishPi:~# bash rpi_6wtsmh5sec.sh -v
dir exists
grep: /etc/myDevices/AppSettings.ini: No such file or directory
Invite code does not exist but directory does so we will add invite code
rpi_6wtsmh5sec.sh: line 14: /etc/myDevices/AppSettings.ini: No such file or directory
rpi_6wtsmh5sec.sh: line 15: /etc/myDevices/AppSettings.ini: No such file or directory
rpi_6wtsmh5sec.sh: line 16: /etc/myDevices/AppSettings.ini: No such file or directory
Failed to stop myDevices.service: Unit myDevices.service not loaded.

This is how far i get and as in first post, app sticks on stage 1

This is screenshot from galaxy tab s2 in full website mode

I think also i have wrong kernel as said before but the code to revert it does work either, terminal complains about me needing to do it manually

Staying on the topic of the install issue for a moment, I think there is a partial install of the Cayenne agent around from a previous install attempt that is throwing things off. Try this command to delete it:

sudo rm -rf /etc/myDevices

then re-run your sudo bash rpi_xxxxxx.sh -v script again. If it fails show me the new output.

If you post your output from uname -a I can confirm if you have the incompatible kernel. I’ve not seen the downgrade command fail like you described above, but if you share with me the output from attempting it I can have a look and see if I can find a solution for you. Either way the whole kernel thing won’t impact install, so I’d focus on installation first.

Finally, I’m going to say our website just wasn’t designed with a tablet browser in mind – I do apologize for that since it should work if its not forcing you to the App Store, but you’re missing ‘Back’ and ‘Next’ buttons that are necessary for you to navigate:

I wouldn’t worry about it because you have an invite code as I can see above, you don’t need to generate a new one, we should be able to get you installed with the existing one.

Actually, regarding those ‘Back’ and ‘Next’ buttons: On my Galaxy Tab, I can see them if I pan around the website – just under a lot of that grey border. So it may be functional yet on this device. I’d be curious if you can too.

Found the next buttons but nothing after that just to install the app either with app or manual which i have tried both and nothing i have looked at kernel number and it seems im running 4.4.34 v7 will this be a problem if trying to install via wifi

Good, then you don’t need to worry about the kernel issues with webiopi.

What I wanted you to try was the manual install again, but AFTER running the command

sudo rm -rf /etc/myDevices

to clean up the partial install you had before. If it works, that’s great, but even if it fails, hopefully it will be for some other reason, and you can share the command line output from your latest attempt for further troubleshooting.

Tried it with same errors as before

Looks like im going to have to strip the unit and get a screen to it, vnc isnt enough when not responding in this way i dont know whats happened but it needs cleaning a fresh again and try again or i may just leave it i have the light working for the time being.

A fresh Jessie image might be the most time effective solution if you don’t have much on the Pi you really care about overwriting / re-setting up besides Cayenne. :slight_smile:

That said, I’m convinced the command line installer will work here, so I’m happy to keep helping troubleshoot if you’d prefer. If you want to go that route, I’m really curious that you got

dir exists
grep: /etc/myDevices/AppSettings.ini: No such file or directory
Invite code does not exist but directory does so we will add invite code

after running sudo rm -rf /etc/myDevices which should have deleted that folder and all of its subfolders. Did it return any sort of error when you ran it?

No error code returned when typing to remove folders just straight back to main terminal line… then tried the install again to get the same error codes 14,15,16 as above