Slider value '0' not working

  • Device & model you are using : MQTT.Fx 1.7.1
  • What dashboard are you using? Web
  • Having a widget slider (channel 1, Slider, analog, min=-5, max=5, step 1)
    The value ‘0’ is never published. All other values, are working fine.
    Also with min=0, max=100, the ‘0’ is never sent to my client.
    I thought I have used it already in the past…
    Do you have any idea? Is it a bug by Cayenne?
    Rgds, Cypress

i just tested it and i was able to successfully get the zero value.

Thanks Shramik.
Can you please tell me how you test?
I am, using MQTT1.7.1 …

  1. Connect to Cayenne
  2. Subscribe to my slider channel: v1/c5*67/things/e6f9/cmd/1
  3. Move my slider to e.g 58 -> 3KCuEuGsuK9LI7H,58
  4. Move my slider to 0 -> no reception
  5. Move my slider to e.g 10 -> EuvDuqHJInCnCp7,10
    Only for 0 I do not see any reception?

okay, i see an issue, at sometimes it works and sometime it doesnt. can you try this: remove the previously added slider and add new as --> add new —> devices/widget —> actuator —> generic —> pwm.
this is only for MQTT.fx. but the slider works perfectly for hardware devices.

works perfectly for hardware devices.

Not for my device. I am using no Cayenne library on my device but have implemented the MQTT Cayenne protocol by my own, while testing in parallel with MQTT.fx instead of my device

MyDevice <-> Cayenne Slider failed
MQTT.fx <-> same dashboard, slider failed.

So what I like to implement is a slider to control a LED on my Hardware Device. Just for testing MQTT.fx substituts my hardwarde device.
I think I cannot go your approach, as I have to add:
Custom Widgets -> Slider … to my Cayenne Dashboard
Or am I wrong?

have you added device as “Bring your own thing”? can you add a new device as arduino `add new —> devices/widget —> arduino". then follow the above steps to add a generic pwm.

Yes, this works.
So what is the problem with my own thing?

just use arduino, you can change the name in the setting of the device to whatever you want.

okay, but I chekced and again the Custom widget Slider looks to be the problem … this also does not work (at least ‘0’ does not work either) with the Arduino device.

dont add custom slider use pwm generic widget.

But generic PWM does not wotk with my own thing :frowning:

why are you using bring your own thing? use arduino only.