Trigger is not working


I tried. But it didn’t work.


@rsiegel tagging for this.


@makerdemynew @shramiksalgaonkar

I suspect there is an issue with MQTT triggers on our end rather than anything with your code, as I am able to reproduce in a test with a very simple trigger. I’ll investigate with our engineers and update as soon as I know more.


Thank you rseigel.
I really appreciate the support.


So what I found in my testing, and at least for my own reproduction case, is that rather than any global issue with triggers, it was something specific to my devices/widgets/account, as the same logic worked fine in a test on a clean account.

We’re of course still looking for the root cause because there must be a subtle bug in here somewhere, but in the meantime, if you’re not too attached to any historical data on your widgets, I’d try deleting/recreating the trigger rule, the widgets, and maybe even the device, to see if you can get the expected performance.


Please clean my account.
Thank you.


There is nothing I can do on my side unless you share your credentials with me. If you’re having a similar issue, try deleting/re-adding the trigger rule itself, as well as the associated widgets/device.


I understand.
Thank you.


I moved! It was completed! ! !
Thank you!


It still not working after even I tried changing the account. Can you please resolve this


When I deleted all widgets / device, I solved it.
When I changed the channel setting of the device I made again, it stopped working.


Hi There, looks like now any of the triggers aren’t working digital used to work and now either digital and analog. Could you you please confirm if this would be stable some time soon since we need to make a decision on what provider we will use for our application and Cayenne Seem to be not stable with this.

Thank you!


I’m on same situation, Thermistor trigger not workink even the temperature is showed on widget and actuator works fine thru the widget also…


Can you try deleting the trigger and re-adding it? Sometimes this will fix the issue.


Same situation here, neither of triggers work since moving to mqtt.
Deleted and readded but still nothing.

Edit: I still have one device using old cayenne lib, and when i try to set trigers using mobile app, only that device is showing as available, the ones using mqtt are not showing in the list.
If i go to trigers in project tab, it shows only 2 trigers even if there are more than 3 created, when selecting triger from left side dropdown it shows all 3.


@Agroelektronik i have also faced similar problem with trigger but i have noticed one think but not sure about it. can you post a screenshot of your dashboard, trigger and device tab open on left side.



Looks to me that the problem causing this is that sensors are added as Analog by the mqtt, maybe i am wrong


a solution is try a simple trigger with basic MQTT code like increment x and send it on channel 1 and add trigger when x reaches at certain value turn on digital output on channel 2.
if this works then there is no problem with MQTT(which worked for me).


The example is ok and workable but not user friendly.
Also you can not use this workaround with mobile app because no actual sensor placed by mqtt is recognised by trigger part of the application, only old ones using old lib.

Just a hint:
Light in your room stops working because of broken light switch, if you conect 2 bare wires together and you get light bulb to work does that automaticly fix your light switch?


i am just asking you that to test a basic analog sensor trigger to find out where the problem is with cayenne trigger or something else.
for me what i did is added a analog sensor randomly and trigger worked.
so next if this trigger is working you have to find what causing the trigger to not fire