Bug Filed on 02-18-2016: Disable logging


#1

Hello,

My /var/log/myDevices.log file keeps filling up the space on my Pi. Its the same error over and over again.

  • myDevices - ERROR - Monitoring failed
    Traceback (most recent call last):
    File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.17841-py3.4.egg/myDevices/sensors/sensors.py”, line 111, in Monitor
    self.MonitorSensors()
    File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.17841-py3.4.egg/myDevices/sensors/sensors.py”, line 127, in MonitorSensors
    self.SensorsInfo()
    File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.17841-py3.4.egg/myDevices/sensors/sensors.py”, line 274, in SensorsInfo
    jsonDevices = self.GetDevices()
    File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.17841-py3.4.egg/myDevices/sensors/sensors.py”, line 253, in GetDevices
    devices = self.SendRequest(‘GET’, ‘/devices/*’)
    File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.17841-py3.4.egg/myDevices/sensors/sensors.py”, line 241, in SendRequest
    response = self.client.sendRequest(reqType, url, body)
    File “/usr/local/lib/python3.4/dist-packages/myDevices-0.1.17841-py3.4.egg/myDevices/sensors/client.py”, line 65, in sendRequest
    raise Exception(“Missing credentials”)
    Exception: Missing credentials

Is there a way to disable the logging?

Thanks,
KC


Temporarily stop myDevices and webiopi?
#2

Hi,

Did you change your WebIOPi credentials after installing Cayenne on your Pi? We’re thinking this is why your are getting the error.

-B


#3

I did change my password, yesterday. What do I need to do to fix Cayenne?


#4

Yeah, so this is a bug that we’re going to work on. We were hoping that no one would run into it before we released the fix, but looks like we have a winner! Congrats :slightly_smiling: But seriously, sorry about this.

Here is what should fix it below:

sudo webiopi-passwd
[Press Enter]
For the login, type ‘webiopi’
[Press Enter]
For the passowrd, type ‘raspberry’
[Press Enter]
then type ‘sudo service webiopi restart’
[Press Enter]
type ‘sudo service myDevices restart’

Also, in your /etc/webiopi/config you must have

[HTTP]
enabled = true
port = 8000
passwd-file = /etc/webiopi/passwd

Please let us know if you continue having issues.

-B


#5

That worked.

Question about your question above "Did you change your WebIOPi credentials after installing Cayenne on your Pi? " How can I uninstall Cayenne and start over? My Pi is open to the internet and I don’t like leaving the default password out there like that.

Thanks,

KC


#6

We have yet to implement an ‘uninstall Cayenne’ button, if you will. What we’ve been recommending is doing a fresh install of Jessie/Wheezy on the SD card and then going through the install process again. You put Cayenne on the newly formatted SD card by adding a new Raspberry Pi to the dashboard: click the ‘add device’ button in top left and then continue with adding a new Raspberry Pi from the available listing under Microcontrollers.

-B


#7

@kscavitt Moving this to the ‘Resolved’ category. Please let us know if this issue comes up again, in regards to logging.