Bug Filed on 04-06-2016: Getting email notifications every minute, can't stop them!


#1

1. What OS? (Wheezy or Jessie) Jessie


2. What class/size SD card? (ex. class 10 16gb) 16gb


3. What Model Pi? (A+, A, B+, B, Pi2) Pi2


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

I have a Raspberry Pi 2 running Jessie . I had installed cayenne to access it remotely using my iPhone. I had also setup a trigger to send me an email if the system was offline. I have since uninstalled cayenne myDevices and deleted the trigger but I am now receiving an email every minute stating:
“myDevices is running.
webiopi is running.”

the subject is “Cron root@raspberrypi /etc/myDevices/crontab.sh”

How can I stop these email from coming and flooding my inbox?


#2

I don’t have a pi with Cayenne on it right here but you can try “crontab -e” to see if you have anything in crontab. Just wipe out anything Cayenne related if there’s anything in there.


#3

Thanks for the tip. I had already tried that but nothing in there :slight_frown:.


#4

Yikes, okay so here’s what you should be able to do to resolve issue immediately:

sudo rm -rf /etc/myDevices && service myDevices stop

You should also remove the Pi from your account since you deleted Cayenne installation from the Pi.

  • click on the edit icon next to your Pi name in left-side device list.

Curious, how did you uninstall Cayenne?

-B


#5

To “Uninstall” i used the option on cayenne.mydevices.com. I don’t remember the exact wording but when you select the properties for a device it says something like “remove from device, this option can not be undone”.

running the above commands changed the email, now the email says:
"/bin/sh: 1: \etc\myDevices\crontab.sh" not found"

so it seems to have cleaned up the files but is still generating the emails.

I checked with services --status-all and the myDevices service is no longer listed.

I have changed to configuration to the /etc/ssmtp/ssmtp.conf by comenting out the ‘mailhub’ as a temporary fix so that it stops sending the emails, but I need it to stop trying to send them. :grin:


#6

Hmm okay.

Did you actually delete the trigger from your trigger setup? Or did you assume that remove the device also removed the associated triggers?

-B


#7

I removed the trigger as well, currently no triggers in my account.


#8

I PM’d you for your account info. If it’s okay with you, I’ll pass your login credentials to the team so we can take a look.

-B


#9

Yes, already sent.
Thanks.


#10

@rkoutnik Can you turn off your pi and see if the notifications are still received?


#11

No, if the pi is off the emails do not come. I did find the problem though. I had checked with crontab -e and made sure there was nothing there related to myDevices or the issue and there was not. Today I found out that crontab is user specific. So I ran sudo crontab -e and found * / * * * * * /etc/myDevices/crontab.sh
I removed the line and saved the setting, re-ediable the email mailhub and I am no longer getting the alerts.
Thanks for all the help.


#12

You are right, oversight on my part. Should have told you to use sudo.


#13

You had the right idea though, thanks.


#14

Hi @rkoutnik,

Just wanted to confirm, you are no longer receiving the emails right?

-B


#15

Yes, the issue was resolved. It seem the uninstall did not remove the task that it had created in the root’s crontab. So when I checked with crontab -e it was not shown, but checking with sudo crontab -e showed the task and I was able to remove it.


#16

Phwew.

We are implementing an uninstall button on the dashboard, so this shouldn’t happen again. Thanks for working with us!

-B


#17

I have an almost identical problem, except I started getting an email every minute after I first installed Cayenne (instead of after uninstall). Even though this bug is set as “resolved,” the subject is exactly the issue I’m having. If I should create a new bug/question thread, I’m happy to do so.

The email subject is: "Cron root@raspberrypi /etc/myDevices/crontab.sh"
and the content of each email is:
myDevices is running.
webiopi is running.

I restarted my raspberry, no change. In order to stop the emails (other than a possible New Year’s gift), I have changed the crontab from:

          • /etc/myDevices/crontab.sh
            to:
    • 1 1 * /etc/myDevices/crontab.sh

The emails have stopped, but I’m sure that Cayenne must need/expect the crontab.sh to run every minute. Because I’m new to Cayenne, I don’t know what might not be working properly now. I’ll leave it this way until I get some feedback about what I should be doing next.

As a semi-newbie, I’m not sure exactly how to find out what I’m running. The Cayenne web page info says “OS: raspbian 7 (debian) Hardware: Model B” but ssh login message says “Linux raspberrypi 4.1.13+ #826 PREEMPT Fri Nov 13 20:13:22 GMT 2015 armv6l GNU/Linux.”


#18

What was the event that you scheduled? We’re trying to find root cause here, it’s been tough to locate.

-B


#19

I’m going to re-open this bug too.


#20

I didn’t have an opportunity to schedule an event or do anything else. I installed Cayenne on my RPi, and the emails immediately started coming in (I received the “myDevices Cayenne - Install Complete” email at 9:02pm and received my first cron email at 9:02pm as well, then every minute thereafter until I could change my crontab). I don’t know if it matters, but I have installed a few other packages on RPi (before installing Cayenne) that I use for other projects, including Apache, ssmtp, ouimeaux and node.js.