Added slider Android crashing, Web working perfectly


##Bug / Issue
Added a slider to my device. The slider is working fine in the web environment including how it intended to work creating an twilightzone before sunset.

CAYENNE_IN(V18) // time offset slider for twilightzone V18
time_offset = getValue.asInt(); // 0 to 1023

Used later in one of the routines:

if (time_now >= time_sunset + time_offset || time_now <= time_sunrise - time_offset) { //delay for twilight offset set by slider
Cayenne.virtualWrite(V24, 1);
//Serial.println(“Twilight = 1”);
} else {
Cayenne.virtualWrite(V24, 0);
//Serial.println(“Twilight = 0”);

Full sketch including flamingo library as zip->txt: (5.4 KB)

Not sure if the slider is the real problem, i have tried the slider in various settings with the main objective to get the raw data and not a converted one, And the end I was successful with a virtual one. During those moment I have seen seen the slider working in Android but web settings like step +5 became +0.1 again.

I notice more differences beween web and Android: often the Android resuffles the layout of the widgets and layout is not the same anymore as the web version.

Please let me know if you need more detail.

##Device & model
Arduino Uno with W5100 ethernet shield

##What dashboard are you using?
Web - working fine
iOS - not using
Android - crashing (after installing slider?)

##Some Pictures

the new slider:

Twilight still green/on:

Twilight to grey/off


Think I already partly solved my own problem by deleting the slider and add it agaqin, however I could not find this issue and created a new one.

However still have a problem because I want to keep the RAW data and not a converted value.


Hi @wj4me,

We’re working on the raw data part, keep you updated! And thanks for updating your post with the fix/work around :slight_smile: