Android stopped: slider problem


#1

##Device & model
Arduino Uno with W5100 ethernet shield
##Dashboard
Web, Android
##Bug
My problems with Android started this week
Initially Cayenne crashed completely, after clearing cache only one device crashes (I have used Android feedback to report this). Did my problem started with adding a slider? not sure at that moment.
I went through all widgets in the web environment to re-save them; did not solve the problem.

##Solution
Deleted the slider in the web environment and was able to access the device again in Android
Tried to add the slider in Android again: virtual-voltage-float-range-0-200 (no step available)
1st attempt failed due to “could not connect to server”.
2nd attempt with success (did not use custom range)
Because range was only 0 to 1 change it into 0 to 200 with success.
Tried some actions slider/lights with success and closed Android APP.
Added step 5 in slider in the web environment, Android still working and order not changed closed APP.

##However
Seems my crashing problem is solved but how did I configure my slider? The values are converted. I just want to use the RAW data from my slider. So 85 stays 85 and is not converted to another value. can i achieve this? With which settings? Help question?

##Small additional problem: re-shuffling widgets
Re-shuffled widget order in Android because it did not match the web version.
Went back to web changed a widget but not the order, back in Android still desired order.
In web changed order a bit closed page and opened Android widget order was reshuffled again.
Seems that you first need to order widgets in web and then you can re-order in Android.


#2

Read the bug broadcast about the slider and multiply by 1023, I did see proper values on the 7th of april for a very short time;).


#3

Hi @wj4me,

Sorry for the late reply here. Yep, this is one of last slider issues we need to fix. We’re working on it, keep you updated!

Will also look into the Android problems you described.

-Benny


#4

I got the same situation , slider data not updated , or changing on android .

On the web it’s working fine.


#5

which app version are you using?


#6

my apps, is a thermostat using an esp8266


#7

1.5.7


#8

it is working at my end. can you PM me your account credentials so that i can test it out at my end.


#9

I got , my cell phone beside me , & a web browser open at the same time , and first on andoide cell phone , the slide is showing -7.0 , and on the web browser it s showing 2.0 . I tryed to change the slide value to 10.0 , and on web its still showing 2.0.
So on the Android apps the slide value is not updated.


#10

can you PM me your account details?