Arduino can' t connect

arduino
#6

@maletils @costas.petridis @jesse.a.slone @rogal1985 We’re looking into this guys, keep you posted.

-B

#7

@maletils @costas.petridis @jesse.a.slone @rogal1985 When you have chance, can you confirm if still having the connection issues? We did a fix.

-B

#8

Yep, it works know, but one of my auth codes changed while fixing.

:slight_smile:

#9

Works for me as well, thank you.

#10

Works with serial too :slight_smile:

#11

Works like a charm:)

In case needed i got a LM35CZ, DS18b20 and DHT11 working all together :slight_smile:

#12

Seems that today we have the same problem, Arduino nano (with serial comm) cannot connect to server
socat reports the following and tries to reconnect

Connecting: FILE:/dev/ttyUSB0,raw,echo=0,clocal=1,cs8,nonblock=1,b9600 <-> TCP:arduino.mydevices.com:8442,nodelay
2016/09/22 15:52:03 socat[2268] N opening character device “/dev/ttyUSB0” for reading and writing
2016/09/22 15:52:03 socat[2268] N opening connection to AF=2 54.86.250.218:8442
2016/09/22 15:52:03 socat[2268] N successfully connected from local address AF=2 192.168.1.11:46994
2016/09/22 15:52:03 socat[2268] N starting data transfer loop with FDs [5,5] and [6,6]
2016/09/22 15:52:03 socat[2268] N socket 2 (fd 6) is at EOF
2016/09/22 15:52:04 socat[2268] N exiting with status 0
Reconnecting in 3s…

#13

Seems to be down for me as well.

#14

@costas.petridis This was a server issue on our side which be believe to be resolved now. Please let me know if your Arduino is connecting OK once again.

#15

Yes, it work now :slight_smile:
thank you

#16

Glad to hear it, our apology for the downtime, we’re investigating so it doesn’t happen again.

#17

@costas.petridis @adam sorry for the downtime guys, thanks for hanging in there!

-B

#18

what about to add feature on the site that displaying server status?

3 Likes
#19

@kuncono

A great suggestion, in my opinion. Thanks for signing up for the community to let us know. I’m partial to pages like this where you get a concise overview that you can trust without having to dig it out of the middle of a cluttered conversation like this.

#20

Arduino uno Wifi Shield
Arduino can’t connect to cayenne.mydevices.com:8442 just trying and stays like this.

#21

Did you update the firmware on the WiFi shield?

-B

#22

Hi,

I am using Arduino UNO R3 with W5100 ethernet shield. I have uploaded the sketch in the Arduino with token assigned to me. I am using Airtel Broadband connection and D-Link Modem. I have connected ethernet cable between modem and W5100, but Arduino cannot connect to Cayenne. mydevices.com:8442. The serial monitor is showing the following message:

[0] MAC: FE-D6-E0-DC-E3-CC
[0] Getting IP…
[60445] DHCP Failed!
[0] MAC: FE-D6-E0-DC-E3-CC
[1] Getting IP…
[60446] DHCP Failed!
[1] MAC: FE-D6-E0-DC-E3-CC
[1] Getting IP…
[60446] DHCP Failed!
[0] MAC: FE-D6-E0-DC-E3-CC
[1] Getting IP…

I have tried disconnecting and reconnecting, without any luck. Can anyone please help.

#23

It’s a long shot, but check out this post Connecting Issue with Arduino uno and Cayenne Via Ethernet Shield W5100

If that’s not it start troubleshooting the physical hardware like network cables and the equipment connected on the other end of the cable.

#24

Thanks Adam for your advice. My UNO R3 and W5100 is now connected with Cayenne server and I can see the status through your smart phone app. I replaced my D-Link modem with Binatone modem and connected the UNO USB cable to a USB hub. I guess, either my computer USB port was not being able to supply adequate power to UNO R3 + W5100 or, there was communication voltage level issues with the earlier D-Link modem. Thanks once again as it was a hardware issue.

1 Like
#25

I have a problem in using Ethernet Shield. Output on Serial Monitor:

[0] MAC: FE-A5-9B-69-A9-CF
[0] Getting IP…
[5783] My IP: 192.168.40.70
[5784] Connecting to arduino.mydevices.com:8442
[10785] Connecting to arduino.mydevices.com:8442
[15787] Connecting to arduino.mydevices.com:8442
[20788] Connecting to arduino.mydevices.com:8442
[25789] Connecting to arduino.mydevices.com:8442

I have tried to write my code to connect a database server (without Cayenne) and store the data and it was OK.
I also have given a command to ping arduino.mydevices.com but I always got Timeout.
Any suggestion to solve this problem? Thanks