Arduino Uno 'Invalid auth token' [solved: faulty hardware]

What dashboard are you using? (Web, iOS, Android)

What OS? (Jessie, Wheezy)


What Model Pi?


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

After uploading the sketch for my Arduino Uno, the serial monitor states:
‘Connecting to
‘Invalid auth token’.

Hey again Lance!

So you have a unique situation because you were using out staging environment for the Beta Arduino focus group session. In short, you are pointing to the wrong servers right now, hence the 'connecting to staging…"

What you’ll need to do is delete the existing Cayenne library that you have on your Arduino IDE, and re-download the library from the Arduino IDE. Below are the steps that should get you online in no time:

  1. Delete existing Cayenne library. You’ll need to manually delete the Cayenne folder from the “libraries” file on your computer.

  2. Now, you can re-download the correct library through the Arduino IDE: Sketch tab → Include Library → Manage Libraries → search for ‘Cayenne’ and download.

I’ll attach screenshots momentarily!


It looks like you have the staging (alpha testing) libraries installed because it is trying to log you into the staging server. The regular library should try to log you into -
[5524] Connecting to

I’ll take a quick look and see if I can track down the proper link.


I beat you :slight_smile:

Seems Benny is faster than I.

Sorry I’ve been gone so long. The new library fixed the ‘Invalid auth token’ error. The sketch loads without error, but the serial monitor shows:
[0][0] MAC: 90-A9-ED-E9-A5-C9
[0] Getting IP…

It never gets an IP address. I don’t know if I’ve done something wrong or if the ethernet shield is faulty.

Do you have any insights.

Last weekend I received 3 Ethernet shields from Amazon. One of the three did exactly what your are explaining, the other two worked fine in the same circuit. One was returned DOA.

Are you fortunate enough to have a spare?



Make sure you don’t have anything shorting out against the top of the USB connector on the Arduino. Some shorter legged shields will allow this to happen. This happened to me, I now have tape covering the tops of all the USB connectors.


I dont have a spare. I’ll pick up a couple. I kept thinking it was user error.

Keep us updated once you pick up a few, would love to see this working for you!


Supposed to arrive today. I’ll let you know by this evening.

I’ve been playing with a 5100 series and a couple 5200 series shields on a genuine and clone Uno’s this morning. Read through the sketches before you upload them. I have had a couple of cases where the supplied sketch (which is to be copy/pasted) doesn’t jive with the original blank setup sketch. *Also verify that your token is correct for the device, the copy/paste version needs you to type in your token for it to work.

Sorted out pretty quickly for me as soon as I went back to the IDE and started actually reading the sketch and correcting what needed it.

1 Like

Success! The new ethernet shield works great! I did have to read through the sketch and make adjustments(change CayenneEthernet.h to CayenneEthernetW5500.h) for my 5500 series. Then I was able to get the correct token and everything worked!

1 Like


Great to hear!
I’m sorry it ended up being faulty hardware :heavy_dollar_sign: :heavy_dollar_sign: .

If you get a chance post some photos of your project.

@bestes Benny I think this can be marked resolved.


1 Like


Hi guys, i´m having the same problem.
Using arduino uno on com 3
ethernet shield w5100
getting ==>
Getting IP…
My IP:
Connecting to
Invalid auth token

i´ve compiled with correct token
any help ?? :slight_smile:

Hi @ricardo.meneghello,

Welcome to the Cayenne community!

Weird, looks like you are connecting to the wrong servers. Do you know where you found the link you used to download the Cayenne libraries? If we are pointing you to wrong Cayenne libraries then we’ll need to fix that.

Thank you!


I download it directly from the Cayenne site.

We have multiple locations where it can be downloaded, would you mind sharing a screenshot? …Did you download from the docs section? Or the Cayenne Dashboard? Sorry about this, it’s hard to pin point which link is incorrect.