Can´t find the conection between Arduino uno and Cayenne

I followed all the steps to connect my Arduino uno to Cayenne online but it doesn´t find my arduino.
I tried to reset my arduino and upload the Ethernet shield W5100 code again but it doesn´t work.
I made sure all the newest codes to be ionstalled but still doesn’t work.
I don´t know how to sent you a scrreenshot of my screen but in the online Cayenne is still says: waiting for board to connect.
I am sure the board is connected to my computer and Arduino app because I tried to upload a simple blink line and it works.
Is my Arduino Uno able to connect itself to Ethernet or Wifi or do I have to buy a component?
Could you help me to solve this problem please? I can´t do anyting.


Welcome to the Cayenne community! Hopefully we can get you going here.

Just to clarify, you have an ethernet shield hooked up to internet, right?

Would you mind posting what your serial monitor is outputting? To view the serial monitor, press the little magnifying glass (I think that’s what it is?) icon in the top right of your Arduino IDE.


I don´t have an ethernet shield. I just have my Arduino uno board.
I immagine I have to buy one am I right?


Yep, you can read about it in our docs section:


Thanks a lot ! I´ll buy it.
Just another question:
I downloaded the Cayenne app on my iPad but I see that it has just the option for Raspberry Pi and not for Arduino Board.
Do you know if there is a version for Arduino Uno board?

iOS not supported for Arduino yet, but we plan on releasing iOS compatibility with Arduino tomorrow!

It’s already been approved by Apple Store.


meanwhile I´ll buy the Ethernet shield.

Could you tell me the difference between the ethernet shield with PoE and without?

POE means Power Over Ethernet.

You don’t need that one.

POE is just a way to power your electronics using the spare wire pairs on your ethernet cable. You have to also have a POE power supply to feed it.



Really thanks for your support.
Let me know when the iOS app is ready!

Best regards!

Hi there !
Finally I have the ethernet shield installed on my Arduino Uno.
I connected them to my computer; Ethernet shield with a red light (PWR) and Arduino with green light (ON).

I tried to upload the blink program but I had some problems.
First of all it takes many time to upload the program and at the end, it appears thius:

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problema subiendo a la placa. Visita para sugerencias.

I don´t know really what to do:
Could anyone help me please to solve the problem?


Try to unplug the ethernet shield. Load your sketch, then put your ethernet shield on. Don’t know anything about the shield, but it could be sharing your serial port.

Let me try

I did so. The sketch is now uploaded. I connected the ethernet shield.
How can I do to know if the shield is sharing the same serial port?
Why I can´t upload a sketch with the shield on?

Probably using some resources needed to program.

On my Pro Mini’s, you need to remove the bluetooth module to program, as the serial port is shared.

To fix it, you would need to add a resistor in line with one of output lines, if you wanted to be able to program without removing the shield. Probably a bit too advanced for you right now.

Congrats on getting your sketch loaded.


Thanks a lot!
So first of all I have to connect my Arduino uno without the shield and upload the Ethernet shield W5100 sketch.
Then I have to connect the shield to my Arduino and the ethernet cable between the shield and my computer.

By doing so the Cayenne App should detect my Arduino.

Am I right?


That looks to be what @Kreggly is suggesting. The only issue I see there is that you will need to plug the Arduino in to a router or switch instead of your computer (unless you have connection sharing turned on). I haven’t run in to this issue yet but it makes sense. I’ll keep that in a good spot in my brain for later.

Thanks a lot!
Unfortunately I still have problem with this.
I connected my Arduino uno to my computer using the usb port.
I installed the Cayenne sketch on my Arduino. Then I connected the ethernet shield on to my Arduino uno.
I connected the shield with the ethernet cable to the ethernet plug in of my computer.
Both, the online software and the ipad app still not find it.

I really don´t know what to do. Please help me I want to start working with Cayenne.

You need to connect the ethernet cable to a switch or router, not your computer.

Hi Adam,
First of al thanks a lot for your support!

Yes you are right…I wrote wrong in the previous post.
My Ethernet cable is connected to my router which has 4 ports.

I have just one activated by the company I am subscribed to.
The company is Axtel Mexico, you can see the router if you look for Axtel
router in google. (Images). It is the white one with 2 antennas.

Still not working.