Attention A-Team Members!


#21

Hi everyone,

i’m trying to install the software on a pi model B where I have already webiopi with 4 temperature sensors(DS1821), 1 pressure/temp(BMP085) sensor and Piface. The installation is blocked at 0%.
I will try to install the software on a fresh pi, installing on an existing webiopi was the convenient approach - the sensors were already there :).

PS Can I attach files to my reply?

Thank you,
Bogdan


#22

Hi Bogdan, welcome.

Yes, please attach any files that might help us better understand any issues.

Let us know how it goes with the fresh install…heads up, we’re still working on supporting the PiFace in our dashboard.

Haven’t seen the install get blocked at 0% before…let us know if it persists.

Thanks,

~B


#23

Hey All

Just Love IOT & The Pi…

Domain - Network administrator by day
Pi Playa @ Night

Current running PI with Lights, irrigation setup via sakis3g for connection.

Hope to contribute and make the product the best it can be.

Regards,
Christopher


#24

Hi all,

I have a Pi Model B running a pre-built image of raspbian for a data logger from Measureit for my power monitor and I’m using a UniPi board.
The default dashboard meters work, all the commands seem to function, I can access the GPIO page and change some of the ins to outs.

The issue is that the GPIO button top right does nothing, and I can’t see how to get any further in adding devices.

I could previously drive relays and read the 1-Wire temp from Webiopi, but I removed all webiopi files and folders before I installed the agent.

Any ideas?

DocPaul


#25

Hi Paul,

Click the ‘add device’ button in top left. From there, you can add various sensors / actuators.

Also, If you connect your one-wire sensor to GPIO pin 4, then we automatically detect it and put it in the dashboard.

You can drive a relay by adding a widget for the relay. Please update us with your progress, hope this helped!

-B


#26

Hi,

Many thanks - I’ve added the UniPi’s MCP23008 and I can drive the relays (although a little intermittent / laggy) but I can’t add the 1-wire. On the GPIO page I see “1-W GPIO 4 ONEWIRE” but nothing on the dashboard. The 1-wire interface is a DS2482-100 on GPIO 0x18.

Thanks again,

DocPaul.


#27

Hi Paul,

Glad you got the relays going. When we release our iOS app (soon) and Android (later), we will use your local Wifi to send commands, whereas the dashboard uses the cloud. This will make the commands much faster on the mobile side. We are working to keep improving the dashboard time too.

That specific 1-wire sensor, the DS2482-100, is not supported right now.

-B


#28

Hi again.

Thanks for the reply - do you know if the DS2482 is on the road-map?
If not, the UniPi also has a MCP3422 ADC, could you add this and the DS2482 to a wish list?

Paul.


#29

Hello everyone!

I’m Dimitris, a software engineer and a maker. :smile:

I am trying out Cayenne at the moment, however I don’t seem to be able to find how to use a PWM output. Whenever I try to click on a device that uses it (servo or digital io) it doesn’t seem to allow me. Any ideas why that happens?


#30

Hey Dimitris!

Good to see you. Try adding the PWM Extension first. Once you adding extension (PCA9865), you can add a widget that references the channel on the extension that you added, such as a light (for dimming), or a servo. We’re working right now to improve our servo integration. Right now there are issues where you need to get the slider in just the right position to make the servo rotate…fixing this very soon.

Right now, PCA9865 is the only PWM that we have fully tested and confirmed works with the dashboard. Using PCA9865 works for dimming an LED though. Hope this helps!

P.S. 0X40 is default slave address for PCA9865

-B


#31

Hi Paul,

Thanks for giving us some input here, it’s on our radar :smile:
-B


#32

Aha, I understand. I thought PWM worked out of the box, without the need of another chip (a la Arduino). Thanks!


#33

Got it. We’re actively working on getting servo out the door, I’ll let you know when that is so you can test it out!

-B


#34

Hi,
i’m Roberto from Italy ,
I installed myDevices at Christmas and now I started to take its first steps .
I have a preliminary question : What is the philosophy ? myDevices relies on a modified version of WebIoPi but how can i config it ? Even with the config file ? Apparently not . I tried to modify user / password and now the dashboard does not "see " the more the system . How can i revert? There is documentation ? Where?
I have a number of devices to be connected ( GPIO Expanders , Sensors , Arduino etc . ) … Where should I start ?
Thank you


#35

Hi Roberto,

Glad to see you finally had some time here.

myDevices Cayenne makes it so you do not need to do any config with WebIOPi, or the config file. You’ll be able to add widgets for your sensors / GPIO expanders / actuators to create your own dashboard and control them. Soon, you will also be able to create trigger logic (when motion detected, turn lights on) and scheduling.

We are working on documentation, but since we are still in a private alpha release, and the early stages of development, we don’t have it yet.

To revert, I would recommend doing a install of myDevices Cayenne again on a clean SD card.

Start with the sensors and go from there. Did this help?

-B


#36

Hi! I’m James Dinsmore, from Melbourne MakerSpace (USA). It took less than 10 minutes to get setup. My Pi2B has the official touch-screen display; was glad that I could simply ssh and load this SW. I like the remote access (just light tightVNC without the fuss); was able to toggle a GPIO port. No problem. I plan on setting up a few more of my PIs to see how it goes; one with Jessie and another with Wheezy; but no issues so far. Happy day!


#37

Thanks for saying hi James!

-B


#38

Hi all,

A Bit late to the game here, admittedly. That being said, I have a fair amount of experience with pi and webIOP. I will crack this open in the next couple of days and let you know what I find out. Good to be here.

Regards,
Dan


#39

Welcome Dan! Looking forward to some feedback from your end.

-B


#40

Hi, i 'm Michalis from Greece. I have an RPi 2. I have installed the software and it seems it is running smoothly. I 'll test it thoroughly the next days. Nice to be here.