Broken Link?

At the moment I can not add an additional Raspberry Pi to my account as when running the following command (as indicated in the Add Raspi wizard)
I get a 404 error. I can’t access it from a browser either.

I am pretty sure when I used this command previously, it had a unique string on the end.

Is this a problem at mydevices end?

Hi @jackhunt,

yes, there should be a unique string that goes where null is. I just created a Raspberry Pi from my account and I didn’t get the null value. Can you try create another Raspberry Pi device through your account, and if you get the null value, take a screenshot and post it? Thanks so much.


Hi I have 2 accounts and have tested it with my older account and it works fine. I logged back in with this one and still no joy.
My new account was setup because I need multiple people to access the dashboard and I didn’t want them to use my personal credentials.

Any ideas?

Just a thought - I did delete a Raspi earlier today as I wanted to rebuild it with a smaller image. Not sure if this as an impact?

Thanks for posting that. I’ve tried to reproduce on my end, not having any luck. At this point, do you think you could share your account credentials with me over a private message, or by direct email (, I can have Cayenne team look at why your Pi is generating a null value.

Please feel free to change your password prior to giving me credentials too :slight_smile:


Hey @jackhunt,

Blast from the past! We’re still waiting for a bug fix for this issue to be approved for our production systems but we have found a workaround for the ‘null’ in the URL. Even if you’re not interested I want to post it here for anyone who runs into this issue and finds this thread so they can have a resolution.

The problem is that you have a “Pending” Raspberry Pi device on your account right now with a null code. If we can delete it and then re-create it, it should generate a code. Complicating things is that our ‘first device’ experience when you have no other devices on your account won’t allow you to reach the device list to do this on your own.

The solution is to add another non-Raspberry Pi device to your account temporarily so you can access the device list, delete the problem Pi entry, then re-create it. So how do you do this? There are a few options:

  1. The easy solution: Send me a private message with your account login and password by clicking on my name on this post, then the blue ‘Message’ button. Then I’ll take care of fixing this and hand the account back off to you. :slight_smile: If you’d like, you can change your password before and after sharing the details at this link.

  2. If you don’t want to share your account login, I understand. If you have an Arduino device, add it to your account by logging in to the web dashboard and choosing the Arduino button when prompted to add a device. Once you’ve added it, you should have access to the device list on the left side, where you can delete the ‘pending’ Raspberry Pi entry by clicking it, then the ‘Remove’ button. Then you can re-add a new Raspberry Pi via Add New > Device/Widget > Single Board Computers > Raspberry Pi, and finally delete the temporary Arduino.

  3. If you don’t want to share your login AND you don’t have an Arduino, Go through the Add Arduino device process anyway until you get to the screen where it offers an ‘Auth Token’. Then message me with just that token and I’ll add an Arduino to your account so you can complete the rest of option 2 above.

Thanks for your patience while we work on this, and let me know if you have any questions or concerns about the above.

1 Like

Hi once again @jackhunt, (and anyone else reading)

With today’s release, we believe that NEW cases of this null issue should no longer occur, so I’m moving this thread to ‘Resolved’. I don’t want to make a change to your account without your permission, but just say the word and I can fix the existing case on your account.

We don’t expect it, but if you or anyone else find this thread and that this issue has occurred on your account past February 2017, please feel free to post here and tag me so we can investigate.

It appears this is not fully fixed (we ran into another case of it today) but we now have reproduction steps that should help us to squash the bug once and for all.

Until I update that we have squashed it, please feel free to PM me with your account credentials if your account gets into this state and I’ll fix it.