First visit step 2 - no invite code

Hi all,

this is what I get when re-asking an invite-code for the installation of a RPi the second time : So there is no script to run in SSH to install the RPi in Cayenne.

I have tried to modify the settings in /etc/myDevices/AppSettings.ini but no result. Still no install script available.
What is the best way to reuse the same RPi as before to have a fresh integration into Cayenne ?

Tnx for replying.

I think @rsiegel knows a work around for this :slight_smile:

We will be fixing this bug, sorry for the inconvenience.



I do indeed know a workaround for this bug. The simplest way is if you could private message me your account login and password so I can fix it for you. It will take just a few minutes. You can reset your password through this form if you want to change it before (and after) sharing:

You can private message me by clicking on my name on this post, then the blue ‘Message’ button.

If you’re not comfortable with me in your account, no worries, let me know and I’ll write up the steps so you can fix it yourself.


I have same problem. It seems that my code is null, because I see:

Please, can you help me? Or what I have to do?


Tnx @rsiegel,

Plz write up the steps so that others also learn how to deal with this bug.
We will manage once you explain what the cause is of the problem not being able to register the device twice on a RPi.


Sure. It’s basically caused by a bug in our First Device add experience. If you click the tile for ‘Bring your own Thing’ or ‘Arduino’ before going back and selecting the tile for Raspberry Pi, it will cause a “null” invite code to be generated for the Pi.

The fix is to remove the pending Arduino or BYOT device from your account. But you can’t access the device list to do this until you have a device on your account! To get another device on your account, you have a few options:

  1. Add an actual Arduino, BYOT, or LoRa device to your account, so you can access the device list, remove the ‘Pending’ entries on your account, and then add your Raspberry Pi (a non-null code would be generated at this point). The pending entries show up grey with an hourglass icon in the sidebar, like this:

  1. If you don’t have any other device handy to add besides your Raspberry Pi, you can either add your Pi as a BYOT device following these instructions, or generate a ‘fake’ MQTT device by entering your credentials into MQTT software like MQTT.fx, as described in this documentation.

I just offered to help since a lot of people who’ve encountered this have no other device, and it’s easy for me to add one to their account, fix the issue, and delete it. Certainly if you have questions about the above let me know, and if anyone else is reading and wants me to fix this issue for your account, just reply here and @mention me, or send me a private message.

1 Like

A great many thanks @rsiegel

our RPi is added to the dashboard after having followed the weird procedure to install the device a second time.

I will try to register this same device now as a Lora device on the TTN with the LMIC library. I had this library installed before but your script made it disappear.
We are close to some lora gateways so we want to be able to send some payload over the air to the TTN backend. From there on, we want to use the new Cayenne integration feature to create/add a ‘new’ Lora device with the this same, already registered RPi.
We will let you know if this is possible.

Edit : it seems like the script is weaping out the WiringPI GPIO access library and replaces it with wiringPiISR, a new GPIO access library. The result is that the GPIO pins on the lora shield connected to the RPi do not correspond anymore. Some further researh to do …

Cheers for now.

1 Like

Bumping this thread to let anyone reading know that the bug was fixed last week and should no longer be occurring. Certainly let me know if you see this moving forward. Thanks for your patience while we squashed this bug!

unfortunately the bug is still there. I wanted to upgrade my 1.0 version of the agent but could not install the new client bcs invitation code did not exist

Can you share a screen shot?