Bug Filed on 01-04-2016: PCA9685 Bug

1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)


3. What Model Pi? (A+, A, B+, B, Pi2)


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

Initially when I installed the PCA9685 device I thought it looked OK (do not recall 100%). After installing the PCA9685 I ran some scripts from Adafruit from command line for some testing and when I came back to the dashboard the sliders go way outside the valid range, goes from -2000 to +2500. Changing the slider within the valid ranges works but obviously going outside that it does not rotate a servo. Tried a service restart on webiopi and myDevices and even a reboot but it did not fix the issue. Tried poking around to figure out how to remove the device and re-add but was not successful in finding that function. Unless I was just not looking hard enough, I recommend adding some way to remove devices after they have been added.

Hi Adam,

We’re going to work on removal of an extension, such as PCA9865. Right now, you can only remove a widget from the dashboard, not an actual extension (oops!).

We’re looking into the servo issue too…hold tight.


This should be fixed. We are still working on ability to remove an extension.