Bug Filed on 01-29-2016: Outputs "unreachable" on dashboard


1. The OS - Jessie

2. The class/size SD card? class 10 / 32GB

3. The Model Pi? - Pi2

4. The bug / issue:

I have relays connected to a MCP23008 which were working great since the last major update, but now they are both showing on the dashboard as “Unreachable”.
On the Extensions page I can see they are configured as outputs but when I try to toggle them, the button just changes to a spinning square.

I’ve just deleted and re-added them, and they are working again, but I’ve not seen any similar reports so I thought I’d let you know.

Paul H


Keep us updated with this Paul. These sporatic bugs are the hardest to squash. At any rate, glad it’s back to normal.

Do me a favor, if it happens again, check the settings for that widget, I’ve seen a case where the
’Channel’ gets changed / removed, which would explain why output toggle doesn’t work. Thanks for letting us know.




Yes, it’s happened again.
The device settings part of the input was blank and the “Extensions” drop down was missing from the dashboard.
I rebooted the pi and the extensions drop down re-appeared. The device is still showing as “Unreachable” but I could add the same device again (with a different name).

Also I’ve tried the iOS app on my iPad and the “Unreachable” buttons don’t appear.



It seems like the dashboard is forgetting the extension that was originally added, for some reason. The good thing for us is that you say everything worked fine until latest update, so this should narrow some things down for us. We will look into this right away. Will update you when resolved. Thank you Paul!



Hi Paul,

Apologize for taking some time to respond here. Was able to look at your account (appreciate you sharing account details!). It looks like the Cayenne agent that’s on your Pi is not recognizing the widgets that you first added. However, when you add the widget again (as you mentioned when you had to rename the widget name), then I think you’ll be good to go.

Can you delete those widgets that are unreachable, and then go through the add device process to re-add them to the dashboard with the MCP23008 as the associated extension? If the widgets are not getting removed when you delete them, try pressing the “Reset” button on the blue bar.

Let me know how this goes!




Not posted for a while, but the widget keeps breaking.
I have to delete it and start again almost every day.

It’s back now but I bet within 24 hours it’s going to be unreachable again.



Hi Paul,

We’ve had a really hard time reproducing this. We have your account info, so @eptak should be able to monitor your Pi so when it happens again, we can see what the issue is.

Do you think you’d be able to leave it online for the next day?



I will look into it asap and will let you know