Bug Filed on 02-01-2016: I had the service running then it stopped


I installed the service a couple of days ago and it showed the normal info for a new device. Today I logged in and it was Offline. I rebooted, no Joy. I tried a reboot/power down still no Joy. What can I do at this point?


Since you didn’t specify what you tried so far, lets start at the basics. Is the pi connected to the internet? Open as SSH session and try the following commands:

ping google.com - if this times out check your network settings with ifconfig and make sure everything is correct
ping cloud.mydevices.com

If you get replies from those commands try some of the commands from my thread when my pi lost connection.

Please run some steps in order to help us debug:

  • provide the output of:
    ps axu | grep python
  • provide logs from /var/log/
    The name of the logs start with myDevices.
  • provide file content from
    cat /etc/myDevices/AppSettings.ini
    cat /etc/myDevices/Network.ini
  • if the processes (webiopi and myDevices) run we may need to enabled debug on the pi

You can also run the service in debug mode to see if there are any obvious errors:
sudo service myDevices stop
sudo myDevices -d


Sorry for the skimpy info.

I can ping google but not cloud.mydevices.com all packets lost. Wierd I setup a different Pi and it is connected and stays connected. The one I am trying to connect is one I have been experimenting with and I had WebioPi installed on it to act as a garage door opener. I tied to connect temp sensors also.
Here is the result of ps axu | grep python
root@raspberrypi:~# ps axu | grep python
root 2003 0.8 1.4 48916 14208 ? Sl 16:27 0:03 /usr/bin/python 3 -m webiopi -l /var/log/webiopi -c /etc/webiopi/config
root 2171 6.5 2.8 122000 26748 ? Sl 16:28 0:19 /usr/bin/python 3 -m myDevices
root 2633 0.0 0.1 3556 1828 pts/0 S+ 16:33 0:00 grep python

If I restart the service it will run for a couple of minutes then go offline. I think I will try a fresh install of Raspian and a new connection. I have installed WebioPi on this device and was / want to use it to monitor trmperatures and also use it to open/close my garage doors. Which it has been doing pretty well at.



Actually it appears cloud.mydevices.com doesn’t reply to pings, I did not know that. There were some issues with people that had webiopi installed previously so a fresh install may be a good idea.


Ha ha. Theres’ your problem. Using mydevices. Can I operate a relay for 2 seconds? I want to operate a relay to open my garage door


Hi elentz,

As of right now, there is no way to set a relay to operate for a specified period of time. You’d have to turn on the relay and then turn it back off, manually. Since Cayenne uses a modified version of WebIOPi, we usually recommend doing a clean install with no previous WebIOPi installed. This may have been the issue you previously experienced.

Ability to specify time period in our roadmap!

Did the fresh install resolve the issue you experienced?




I reinstalled Raspian lite and the run the script to install mydevices. The myDevices page is stuck on Agent. I did a service myDevices status and got back a message that I believe means that the initscript is running. I started this last night and again this morning about 10 minutes ago.


I have similar problem. raspberry run just fine I can se all the info on my computer an ios app, then after some time it say offline app also don’t work. I can SSH raspberry but I can’t ping google. anyone have an idea?


Yeah I had installed the service on a different Pi and it was offline after a couple of hours, I had to restart the service, then it reconected. Something is amiss and I don’t know what it could be.


I did fresh install and no change. same problem…
when I click remote access on a raspberry desktop I have a error say: No session for pid 4709
no idea if this have anything to do with my and other problem but here it is …
thanks for any help


@svazir @akaranfilian Let’s look at this first.

@greku69 @elentz thank you for reporting this to us. We are going to look into this right away.



Hello guys,

As @ats1080s stated we will need the content of some files:

  • provide file content from
    cat /etc/myDevices/AppSettings.ini
    cat /etc/myDevices/Network.ini

If it’s an older version with a known issue on disconnect you may need to manually update your pi.
If it’s a new version we may need to contact you separately and enable debug on your pi in order to pick up the logs.

We will fix it as soon as we have the required info.


@greku69 @elentz if you could post the output from above commands to this thread when you get some free time :slightly_smiling:


Will do Probably this evening.




hi guys.
this is the files info from raspberry after reset so I can copy this via remote access not sure if they are going to be different when I lost connection.

hope this help


@bestes The issue with the remote desktop is a known issue and it should be resolved in one of the next releases to production.


Hi Elentz,

I noticed you installed a Raspbian “lite” on your Pi. We’ve had issues with Lite in the past, so we usually recommend that you install the full version. Do you think you could install the full version of Raspbian and update us how it goes?



I’m on full version of raspian jessie.


Is your Pi on Wifi dongle?

Hmmm, If you can’t ping google.com then your Pi isn’t connected to internet and the dashboard will also be listed as offline if Pi isn’t connected to internet.