Bug Filed on 05-26-2016: Project is offline can't connect

I have had my project up and running on the RPi3 for a few weeks. now the dashboard says it’s offline.
I have rebooted the Pi and I still get the same message. The Pi is connected to the network as before.

Any suggestions?


Are you on Wifi or ethernet cable?

What does following commands bring up when typed in Pi terminal?

sudo netstat -natp | grep -i established

cat /etc/myDevices/Network.ini


On ethernet

Maybe check the service status as well?

sudo service myDevices status
sudo service webiopi status

I’d temporarily disable your router/firewall security settings, and/or assign the Pi to the DMZ and see if you are seeing issues.

Cayenne uses a port that your firewall or router may be blocking.


Here is the screenshot

Your myDevices service seemes to have crashed. Try “sudo service myDevices start” to get it running again, or reboot. After it starts check the status to make sure it didn’t instantly crash again. If it won’t stay running start it with “sudo myDevices -d” to get some more info.

Still not working -d did not reveal anything. I am getting that pam_exec(login:session): conversation failed during the start…

Hi @tony.contrada ,

Sorry you are experiencing this. We’re trying to get to root cause.

Would you mind running this command and posting output?
ps axu | grep python

Also posting the logs would be very helpful in this situation:
tail -f /var/log/myDevices.log




I’m doing some housekeeping today and am going to move this issue to Resolved since we haven’t heard back. Please feel free to post in it with the requested log info if this is still occurring for you.