Bug Filed on 03-28-2016: Android App - Please check SSH configuration



1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)


3. What Model Pi? (A+, A, B+, B, Pi2)


4. My Dashboard shows the PI online. I can connect remotely via the browser and get to the desktop. When I use the Android Cayenne App it finds the Raspberry PI over the wireless, but when I go to login it says “Please check SSH configuration” when I use the login and password. The login is the standard “pi” login with a unique password. No crazy Uppercase Lowercase Symbols type password is being used. Just lowercase password with no special characters. I have confirmed the login and password are correct, but the interface just keeps throwing the error in the Android App. Any ideas. Thanks.


I installed the IOS app for Cayenne. I provided my login credentials and it connected to my PI with no issues. This is something related to the Android App.


Hey Damon,

Thank you so much for testing on iOS and verifying that this is Android specific. I think this will give us enough info to investigate…we had this come up, pushed a fix, but looks like there is some corner case we’ll need to handle. I’ll update this post (likely mid-week of next) when we push an app update for this.

thanks again,



I appreciate the update. Also wanted to let you know that I was kind of surprised that the Android app is only location based, and not cloud based. The IOS app logs into the public cloud it looks like, where the android app wants to do a local network discovery. I could be wrong, but they seem completely different.

At first impression it seems I can use the IOS app anywhere in the world to monitor my raspberry, where the Android seems you need to be connected to your local Wifi network. It would be nice if the app had the same look in feel in both version to give the user a consistent and familiar feel. Just 2 cents. And again, I may be wrong. It happens all the time!



@damon1974 i use the android app outside my wifi and it works perfectly, over 4g and other wifi networks.


Hi Damon,

I’ll always take your 2 cents :slight_smile:

So yeah, Android app is local if you are on your wifi but it should be using cloud if you are, say, at the store. Both iOS and Android should be doing local discovery, and should be able to discover the Pi’s that are connected to the network.



Actually, I just disabled Wifi and the app specifically says you need to be connected to Wifi.

Exact Quote: "Please make sure you’re connected to a Wi-Fi network"

So it doesn’t appear to use cloud at this time. Unless you have a newer version. Mine is version 0.0.44a

  • Damon



Damon, welcome to the Cayenne community!

I’m also currently using .44a. and I have not had a problem with Cayenne on either another network WiFi or 4G, in fact today I was showing a co-worker the temperature trend at home while on the other side of the county. Sadly that anecdote isn’t much help to you.

I’m wondering if it could be a setting in your phone/tablet that is restricting Cayenne. For example my phone, Samsung S5, has a ‘Restrict background data’ setting.

On my phone its found in Settings > Network connections > Data usage > 3 dot drop down menu > Restrict background data

I’m not sure if this will help, but I thought I would share.

Good luck,



Hey Damon,

So the way both iOS and Android work is that once it has our Cayenne agent, it can connect and monitor the pi from anywhere by connecting through the cloud. However, in order to install the Cayenne agent onto the pi, the iOS and Android apps both have to be on the same network as the pi so it can SSH into the pi and run the installer. So when you first use the app and don’t have a pi on your account, you will need to be connected to the same network as your pi. Once you have a pi on your account you can connect to that Pi from anywhere but if you want to add another Pi to your account you will have to be on the same network as the new Pi again.

Hope that answers your question.
All the best,



Thanks for the insight!



I am remote now. Same error. Checked background data. No restrictions. I am using a Nexus 5X with the latest Android 6.01. (Whatever the current version is. )


Fixed it!! Had to force stop, then delete app data. It was stuck in some sort of first time setup. I think I know what I did. I started the app before I had a Raspberry PI logged into the account. So it logged in, but saw no PI.that made it go into the add one mode. And it didn’t want to leave that mode no matter how many times I killed the app and relaunched. It just wouldn’t see the already added PI on my account.

Glad I got it working. Thanks for everyone’s help.



Glad to hear! Sorry I didn’t have the right answer, but very glad you were able to solve the callenge.



Just wanted to comment here for any future readers that we’ve made additional updates to the Android app, released today (version 1.0.3) that should resolve these ‘Check SSH configuration’ errors.

To update the app on your Android device, visit the Play Store app > My apps > Update