Bug Filed on 05-12-2016: Problem with the android app(first time setup)

What dashboard are you using? (Web, iOS, Android)


What OS? (Jessie, Wheezy)


What Model Pi?

Pi 2

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!
So i just installed the app on my android (6.0) the app detects my pi normally…i check the little box and hit setup…it opens up the login bar for me to enter my credentials and when i hit install-setup it just says “please check your ssh configuration” but the credentials are right and im actually able to ssh to my pi from my pc…

Hi v4lent1nos4146privat,

My apologies for the trouble you’re seeing, and thanks for the bug report.

I’ve seen another user with this issue who was able to resolve it by Force Stopping the app from Settings > Apps > Cayenne > Force Stop, then on that same screen, tapping ‘Storage’ and Clearing Data as well. In their case the app was in an odd state and simply restarting it in this way was enough to get past the SSH error. Let me know if you have any success with that.

We’ve done several update releases to the Android app since this topic was created. I’m going to resolve this topic, please let me know if you continue to experience issues, after making sure you are using latest version of Cayenne android app. Thanks!


hy i downloaded the app but i get the error: can’t continue, SSH error…
i cleared the data as instructed above and restarted the app but the same error. the steps that i am taking are:
1 search the raspberry-doesn’t find it so i use the ip
2 select it to setup-sometimes it asks for user an pass so i tipe them
3 i get the message: can’t continue need at least 200mb… and after a few seconds it says step 1 installing libraries… and after a few seconds i get can’t continue SSH error…

thx for the help in advance

Can you run the command df -h in an SSH session and paste the results here?

and there is another problem lately. it prompts for the ssh credentials but when i give them it says that they are incorrect. could it be an issue that i’m using the app on an galaxy tab 7 whit android version 4.2.2? i haven’t tried the app with a newer model and a newer version of the android.

again thx in advance

Hmmm. The issue may have to do with tablet you are using. We technically only released support for Android mobile phones. Do you know if you encounter same issues on an Android mobile phone?


i’ll test it on an android phone as soon as i can and i will get back with info

works fine (the info from rasp at least- didn’t tested the functions yet) from phone. i connected the tablet after the phone app did the setup but the connection lasts for a second then i get device disconnected- i’m writing this for other users who may have the same problem i had. all in all the app seams to work nice on phone (for now) so thx guys for creating it and thx again for the support. best wishes for everyone

do you know when and if you will provide support for tablets regarding the app?
as always thx in advance