Bug Filed on 05-02-2016: Server Error



What dashboard are you using? (Web, iOS, Android)


What OS? (Jessie, Wheezy)


What Model Pi?

Pi 2 B

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

Every time I try to add a Light Switch Actuator, when I click “Add Actuator” I get a red bar that says “Server Error”.
Everything else seems to work fine.


Hey @brettwi ,

Is that error only happening when trying to add the Light Switch widget? Or is it across the board for all widgets you are trying to add? Also, try using the ‘generic digital input’ widget and see if that might work in place of the Light Swtitch widget.

We’re looking into a few other Android bugs right now. Checked out our servers and nothing abnormal. This is likely a bad error message on our part. We’ll investigate this in near future and keep you updated. Thanks for reporting.


Android App

Rasbperry Pi 3

Light widget Added

Error pops “Server Error” , not able use the widget.

Can access the Light from the GPIO dasshboard.



Can you use ‘generic digital input’ widgets and see if you’re able to do work around?



I could not add any devices. I uninstalled all software, removed Cayenne from my Pi and re-installed. That worked. Then it crashes if I turn off my Phone, but still am connected on my desktop. The software is very buggy. Needs a lot of work to be professional. But it sorta works, so it is fun to play with…

I can not “drag” a device to add an event.
Looks like we have version 0.8 at best. Keep working on the software!__


Same for me. Fresh install of Jessie on raspberry pi 2 and a fresh install on raspberry pi 3.

Tried Android 4.4 and 5.1.

Server error when I add any device. Disconnected from device messages. Forgets my saved pi’s.

Failed to send command when I select reboot or shutdown.

Reinstalled and same thing.

The only feature I can get to work is the remote access.

Excited for when gets up and running. Looks to be very handy.


@brettwi @jconnerfoto Did you install Cayenne from the Android app, or from the web dashboard and then opened Cayenne app with Cayenne already installed on the Pi?



I opened Cayenne from the android app.

When I close the android app, then reopen it, it asks me to reinstall the software on the Pi, which takes 5 minutes. Then it works again unless I open the web app and try and use both, or close the android app again. The software is getting confused. Some kind of tracking is needed so it does not crash so often. Also when the Android app goes to sleep on my phone, it loses connectivity to the pi, and takes a minute or so to reconnect.


Android app.


I tried to add one with the web app and it added but the device errors “Unreachable”


@brettwi @jconnerfoto Are you installing multiple instances of Cayenne onto the same SD Card?

This could definitely be causing issues. You should only need to go through install process once to get Cayenne onto the Pi. Whether you install through web or mobile app. Then, when you sign in on the Android app, your Pi should appear as a pi that is able to be selected (not installed) and when click the Pi it should take you to dashboard screen.

We are working on a fix where we will be able to detect if Cayenne is already on the Pi. So ultimately this is a bad experience on our side that we’re going to fix.


Gotcha, I can wait until the next version.


@brettwi @mahi @jconnerfoto We released an update to the Android app. Can you make sure your app gets updated and see if this issue you were experiencing was resolved? Want to make sure issue is resolved before moving on to other bugs.

Thank you!



Well, I updated my android software to the latest, and there are still issues with the software. The new software installed on the Raspberry Pi again, and after rebooting, my android found the pi, and was able to control a light after a few minutes of waiting. However “server error” keeps displaying when I try to change any event, and Network speed still shows zero (I am connected via Wifi if that matters). To your credit, Processes now shows 53 and I am able to view the processes and am able to stop or run a process, although the time it takes (over a minute) is much too long.

Additionally, when I run the web interface from cayenne.mydevices.com I can not control the light widget. I just get a continuous spinning wheel (for the last 15 minutes) when I tried to activate the light. You are still blocking input from the web interface and not tracking which is in control of the pi. Ideally I should be able to control the pi from either the web interface and/or the android at any time.

One final note, the event I have been trying to delete finally allowed itself to be deleted after 20 minutes. My second event still shows “server error” when I try to turn it off or on. I suspect you need to invest in some faster servers because waiting 20 minutes to turn something on or off just isn’t going to work.


Thanks for the update.
Previous to the update I was able to log into the web app and add the light switch. It worked form the web app. It did not show in the android app until I uninstalled the app an reinstalled it.
I updated the app and tried to add a light switch and I am still getting server error. It did not prompt me to intall the software on the pi again though.


@brettwi @jconnerfoto Hey guys, we’ve released several big updates to the Android app over last weeks, if you could make sure you have the latest version downloaded, and let us know if you continue to experience issues. Also, leave us a good review on the Google Play store :slight_smile:

See you!