Bug Filed on 07-26-2016: Build for Python 3.4.2 failed

Help me!

HI @pasqualetarantino,

Are you using a recent version of Jessie? I would recommend going and downloading the latest image to a clean SD card and installing again. Keep us updated with your progress!


The same thing is happening to me.
I have download the latest image and installed two days ago.
Is there a logfile??

Welcome to Cayenne!

Have you tried manually installing the python development headers?

1 Like

I am having the same issue I am running an apt-get update and installing the latest version of python to see if this helps will let u know if it works.

I was trying install Cayenne at Raspbian Jessie Lite and have the same problem. I have Python 3.4.2 installed. I run “sudo apt-get -f update” and install manually the headers, but dont work. Any idea?

I answer myself:

I made it work that way

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

1 Like


I hope the commands in tocopulus’s post were able to resolve this for you, and you’ve had a chance to get started with Cayenne. I’m going to mark the thread Resolved since they’ve solved this issue for everyone else who I’ve seen run into this.

Either way, let us know! If they didn’t we’d be glad to keep helping you troubleshoot.