Cannot add more than one Pi to dashboard

  • Device & model you are using: Pi 2 Model B and Raspberry Pi zero

  • What dashboard are you using? Android

I have tried many many times to add another Pi to the dashboard both via Andriod App and via wget both with no sucess… I can get to the gpio-header page and activate the pins on the devces, so this proves that the software is installed. I have even tried altering the hostname on the device but still nothing. I can turn one of the devices off and I can access it via the dash… but cannot have more than one Pi on the dash at the same time. Both devices have static IP both different on the same netmask. Is this a restriction or a bug?


No, you can many Pi’s all running at the same time. Did you generate and use a different installer for each one? The link that is generated on the dashboard to download the installer is actually unique to each Pi that shows up on the desktop. Using a smartphone app to install should do this automatically but manually installing with SSH will require adding a new device for each one. That’s about as far as I can troubleshoot, post back if that doesn’t help and @rsiegel can help further.

What do you mean by this?

I followed the instructions!

I get the same results if I install it by phone app or via wget!

Maybe I am missing something in the install proc can anyone help?

Hi @Martin4

I think the question was, the Cayenne website generates installers with unique invite codes attached to them, for example, but the part after the underscore changes for each device. So if you re-used the same installer on multiple pis, you could run into a situation where the install completed OK on both pis, but the Cayenne Dashboard doesn’t see them as unique devices.