Multiple Pi's dont show up seperately

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Raspberry Pi 3 Model B

*Web and Android Dashboards

  • I am trying to add a 2nd raspberry pi, and when they are complete it shows only one. Also, if i change the name it will change the name for both Pi. Is there a way to resolve this?

Did you use the same auth token for the second Raspberry Pi as you did the first?


No i first did them both with the android app, and when that didn’t work i tried it from the web interface and was sure to use different auth tokens

This evening i took this a step further. I had one new raspberry pi model 3, and one from the first 2 i tried to add. I made a new account. I did full fresh installs from new sd cards. The only thing from the previous install was the one raspberry pi itself. When i added it to the list it saw the other raspberry pi from the other account. It showed the ip address and when i clicked in it was showing the details from that setup not my clean one. occasionally with enough refreshing it would show the actual pi. just as an added note this is on my home network this evening and not the network i am setting these up for.

Any luck on this? I’m also having this issue when trying to add a 2nd Pi 3 B.

Hi @c0lby,

Just to make sure I’m understanding correctly, after adding the 2nd Pi, you’re seeing two Pi’s on your Cayenne account, but if you rename one, then the other gets renamed as well? Are you doing the renaming via the mobile app or the web dashboard? Did you add each pi via the Android app or the command line install?

If so, on the web dashboard, can you select each Pi, go to the gear icon in the upper right > Configure and screenshot that Settings page for each of them so I can see the detail? You can send it to me via forum PM if you don’t want to show the detail publicly here.

Hi @rsiegel,
Well my issue was closer to the OP saying both were showing up as one. So have my 1st Pi connected to Cayenne and my scheduling and everything for my multiple projects are working great - you can see the local IP is

Well, once i add the new Pi, you can see it in the Cayenne dashboard view, but its like it’s taking over my 1st Pi. Here is the screen shot after the 2nd Pi is installed, you can see the local IP is now, and none of my sensors are reachable.

If I unplug the 2nd Pi, reboot the 1st Pi, & remove the 2nd pending Pi on the Cayenne dashboard then everything goes back to normal. I’ve changed the host names on both pi’s before installing Cayenne and both had a fresh copy of Raspbian. I’ve tried on iOS and on the web.

Both Pi’s are Model 3 B and i have a 8 channel relay hooked up to them,

So this is what @bestes was getting at a few months ago, but I want to ask you the same question since it’s my first instinct.

Did you grab a fresh installer from the Add New > Device/Widget > Single Board Computers > Raspberry Pi for each Pi?

The wget line looks like wget but will have a unique code each time to differentiate the devices when they phone home. This looks like it could be a situation where one code got used twice.

@rsiegel Yes, I used a different installer for each Pi. I was wondering how the dashboard knew my boards from anyone else’s but then I noticed the unique code was different on each install :grin:. The working Pi that I have in my garage was setup last night and I used a new installer this morning through the website for the 2nd Pi. Also, when I tried from my iPhone it should have user a separate installer as well, right?

Yes, my apologies, I should have caught that if you were using the iOS app that would eliminate the potential to mix up/reuse the single-use installers.

Sorry to keep bombarding you with questions but, if you run ifconfig on each of the Pis, is the first Pi on your network as 192.168.125 and the 2nd at

If you’re comfortable with PMing me your account login/password (you can change your password first, and after, here) I’d be interested to have a look to see if anything sticks out, and potentially try to add some of my test Pis (and remove them when I’m done), to see if this is across the board or just limited to your specific 2nd Pi.

My final resolution for this problem was to make a new account and use 2 different raspberry pi. The issue with the old ones remain.

I acknowledge that there could be some bug here that we haven’t quite sussed out, but you should not have to do that.

The platform is designed for multiple devices (Pi’s, Arduinos, LoRa, whatever) to be attached to the same Cayenne account so you can use the Projects feature to build projects that have widgets from multiple disparate devices interacting in one Project view, or triggers like ‘If temp sensor on Pi A > 90F then power the relay on pin 8 on Pi B’, etc.

It’s an OK workaround if you’re only interested controlling the devices individually, but you lose a lot of the potential functionality that way.

We are using the 2 new rpis on the same account, but the old 2 are still locked to each other regardless of the account they are on. I was never able to fix that regardless of what was attempted to fix it.

Thanks, I appreciate the information, the more the better for getting to the bottom of this.

I am in the same boat, except i tried adding the 2nd Pi 3 to a secondary Cayenne account and i experienced the same problem. I bought a Pi zero the other day and the hdmi and usb adaptors will be in today so i can test to see if i get the same issue with it added on.