Cannot remote access on raspbian Jessie with Pixel

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield): Pi3 model B

  • What dashboard are you using? (Web, iOS, Android) Web & Android

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!

I just installed a fresh copy of the September 2016 Raspbian Jessie with Pixel on my Pi3. I added the Pi3 to myDevices using the Android App. The pi is found and everything appears to install correctly. After reboot, I can see the Pi3 and get dashboard readings. I can reboot, shutdown, and configure. However, when I attempt to use “remote access” a new window appears with “We are connecting with the device. Ask the user whose PC you wish to access to click “Share This Device.”” After a minute, I get “Desktop Not Responding
Your connection has closed as the remote desktop is not responding. Please wait a few minutes and try again.”

1 Like

Hi, I am with the same problem, below my hardware:
Linux raspberrypi 4.4.21-v7+ #911 SMP Thu Sep 15 14:22:38 BST 2016 armv7l GNU/Linux
root@raspberrypi:/home/pi# hardlink
ERROR: Expected file or directory names
root@raspberrypi:/home/pi# lscpu
Architecture: armv7l
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 1
Model name: ARMv7 Processor rev 4 (v7l)
CPU max MHz: 1200.0000
CPU min MHz: 600.0000

Hi Guys,

You should not be seeing the screen telling you to wait on a user to click ‘share’, it’s possible something broke with the upgraded Raspbian. I’ll try in a moment and update you on what I find


Not sure if this matters, but I did a fresh install of Raspbian Jessie w/Pixel from the most recent image and got the remote access failure. In other words, I didn’t upgrade an existing Pi, I started with a fresh image and Cayenne setup. I actually did it twice with the same remote access failure results.


did you do the sudo apt-get update, sudo apt-get upgrade, then a sudo install rpi-update? This installs several libraries-


On the first fresh install, I did not update anything before adding to Cayenne. On the 2nd fresh install I did all 3 commands. The latest image from was very new, so the updates only found a few updates. In both instances the remote access failed with the “share this device” message.

Just wanted to update. On my first test, which was updating the Pi for PIXEL with the 5 commands on this page, my Remote Access in Cayenne is still behaving.

That was of course updating a Pi with Cayenne already installed. For my next test I’ll try a fresh install of Raspbian, then Cayenne, and see if I can reproduce there.

Final update for today – I can reproduce on the fresh install Raspbian Jessie with Pixel, despite my failure to reproduce on an updated older Raspbian that had Cayenne already installed. So I’ll be able to get this to our development team as a bug with the new Raspbian release. Will update as soon as I know more about a fix.

In the meantime, there are lots of remote access solutions for Raspbian that you could use until we have this fixed: Raspberry Pi Documentation - Remote Access explains lots of options, the VNC page on their site shows alternatives that would be very similar to our Remote Access feature.

i too have the same issue

1 Like

Same problem here. Fresh install on raspbian and cannot connect. Two months now and no solution?

Hi @ashok8182 @cayenne9 ,

We are making some new feature and bug fixes today. Unfortunately the Pixel fix for remote access will not be included with today’s release. Next release, this fix will be included. Very sorry, but hang in there and it will be fixed…likely in Jan 2017 since the holidays are coming.


@ashok8182 @cayenne9 @bestes

Any progress to report on remote access with Pixel?


Hi @burnham,

Unfortunately, our developers are heads down on other priority tasks :frowning: We have not had chance to fix this yet. I’m sorry!


i have the same issue here. intrested in updates when there are some :slight_smile:

1 Like

do you have feedback

Is there an issue with Jessie? Should I downgrade to Wheezy to have this work?

Hi @jody, @michael.dornbierer, everyone else following this thread:

I do have some update on this, in the sense that I worked with a developer to test a fix to this today and it worked well.

It’s not really a problem with the Jessie OS, so much as one of their updates broke the VNC software that we were relying on for this feature. Don’t downgrade to Wheezy over this feature, at least without the understanding that that will probably break Cayenne in some other way, as we dropped Wheezy support some months ago.

If you need a graphical remote desktop into your Pi until we get this fix out the door, I would encourage you to look at this official Raspberry Pi documentation on setting up a VNC connection so you can do it outside of Cayenne. It’s not difficult and may well offer you more options than our ‘Remote Access’ feature currently does, even when it’s working.

If you just need remote access to your Pi’s command line, I’d use SSH

Thanks all for your patience on this one. We’ve been doing a lot of enterprise work and scalability work in order to keep the lights on – as we wrap that up we should have a much better development response time to solving widespread issues like this without them sitting for so many months.


Thank you for getting back to me/us

I am looking forward to the resolution as this looks like am amazing app/product

I am sure from your dedication this will be resolved asap