Bug Filed on 05-02-2016: Remote desktop does not work (not pop-up blocker)

I HAVE turned my popup blocker off and tried it in several different browsers… I was able to connect to my Pi a couple of times and then it did this:

I try to connect to my Pi from the dashboard and mobile app (Android) and it acts like it is going to work but then it says something like “waiting for USER on Raspberry Pi to click to allow access” with a white screen and a blue wheel of spinning dots. I go to my Pi (physical - with keyboard, monitor & mouse) and there is no prompt to click to allow.
Then it just goes to the screen that says it failed to connect.

I removed the device from the dashboard and then re-added it using the mobile app. Still the same thing. Do I maybe need to completely remove the software from my Pi or is there a quicker known solution/workaround/explanation.

Any help would be greatly appreciated. If I don’t hear a response soon I will probably just wipe Noobs Raspian and start from scratch.

Thanks in advance,

Colter McKay ~

I too have not been able to get remote desktop working in chrome / f.fox on several setups for some time. Suggest a “how to allow” FAQ or similar help and directions setting.
~ Andrew

Sorry for the inconvenience this issue should be fixed now. Please let us know if you are still experiencing the issue.


Remote Desktop is now working for me inside of my network and externally using the Android app and a web browser (Firefox). First I Just removed the device from the Dashboard then re-added it. That did not work so I just wiped my SD card and re-flashed the Cayenne image. That also did not fix the problem after the software installed and configured from the app. I waited a few days and “svazir” informed me that the problem should be fixed. I tried it again and it is now working. Thank You for the fix svazir Sumeet! It must have been something on the back-end with my account (it may have been all or many user accounts). I am glad to see that bugs are being resolved quickly even though it is a free service. Keep up the great work.

I am loving your service and I’m very exited to start my first project of environmentally monitoring our server room with sensors. My second project will be monitoring my greenhouse and implementing some “If and Then” triggers like lights, fans, water valves (actuators), etc.

Thank you, thank you, thank you!!!

1 Like

This is also fixed for me. Great thanks

1 Like

Glad to hear you are enjoying Cayenne! If you have some time, we would love to see what you are making with Cayenne. We have a ‘projects made with Cayenne’ category that is specifically made for posting projects to. :slight_smile:


Great to hear!


Remote desktop still a mystery to me…
Latest atempt is on a clean windows 7 (tiny) + chrome and sequence is as follows…

As per above suggestion on setting up a how to setup for dummies / screen captures so we can see what part is breaking including 'un blocking the popup blocker in case I (others) looking in wrong place etc…

~ Andrew

1 Like

In your Raspberry Pi Configuration (Preferences>Raspberry Pi Configuration) make sure REMOTE GPIO is enabled in the Interfaces tab.

Trying to look for this.
I am looking all over my Chrome / PC Desktop GUI and can not see a “Preferences>Raspberry Pi Configuration) make sure REMOTE GPIO is enabled in the Interfaces tab” button slider or page for that matter…
I only have…

BUT… looks like someone flipped the switch for me :slight_smile:

Any update on this / how or why or when this feature is made permenant or more predictable will be great thanks.
~ Andrew

Andrew, I’m guessing @aleforce1 is referring to this-

That said, I’ve not had to change this setting. In fact, the below screenshot is two separate desktops, simultaneously running remotely on the same RPi. One via Cayenne Remote Access and the other via TightVNC.

General info on the RPi from Cayenne
Device Name RPi 3 IP Address (wlan0) 192.1XX.XXX.XXX Agent Version Computer Make Sony, UK Computer Model Pi 3 Model B OS Name raspbian OS Version 8 OS Build debian OS Architecture a02082

This is a RPi 3b WiFi’d into my network running Tuesday’s image 2016-05-10-raspbian-jessie.img.

Cayenne Remote Access is working on all 4 of the RPi’s I have running this morning-
Zero via CAT5
Zero via WiFi
2b via CAT5
3b via WiFi


'Gotcha ! Thanks for this. It is because I use headless for just about everything that will be why I could not get in to see the settings in the first place… Knew I was banging my head against a wall there for a bit so thanks for leading me by the nose… (Nice graphic :slight_smile: )
~ Andrew

1 Like