Cayenne Agent is not able to add the temperature sensor DS18B20


What dashboard are you using? (Web, iOS, Android)


What OS? (Jessie, Wheezy)


What Model Pi?

Pi 3 Model B

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

Cayenne Agent is not able to add the temperature sensor DS18B20, i receive following error :

Please fix the following errors:
Failed to add the sensor, please re-check your settings. Make sure you selected the correct Channel/Slave Address.

However I am able to see the Slave address via SSH and also I have output :

Also , in the “Configure” menu I am not able to turn on SPI and I2C , although they are enabled in raspi-config , they stay disabled in Cayenne.

Please advise how to solve those two matters. Thank you.


to add to this topic, I am not able to access GPIO from the top menu, and also it seems I have a RAM issuе because RAM starts in 50% and in 10 hours it is at 95-98%


Here’s what my config looks like with the same sensor:

Can you confirm that the sensor’s digital pin is to GPIO 4?


Hello bbrohan,
thanks for the reply, yes I confirm that the sensors data pin is set to GPIO 4 (7 on the numeric diagram). Also can confirm that there are 4.68 kiloohms resistance on the sensor (measured with multimeter). I cannot switch any of the options except for device tree - I receive a message “We need to restart your device to do that” but nothing happens when I click confirm (raspberry is not rebooted)


Hi @invailor,

The DS18B20 is a one-wire sensor, so it shouldn’t even be necessary to enter any slave address through the widget creation dialog, in fact, if you’re hooked up to Pin 4 on your Pi, and wire it up with the Pi powered off, when you power back on the Pi it should auto-detect this sensor and add a widget for it to the dashboard automatically.

That settings page is a bit more complicated – it’s currently still in need of development, so despite those toggle switches you see, we’re just reading the values from your Pi itself – think of it as a read-only list of Pi settings would have to be edited outside of Cayenne in order to change their on-off status.

If you need help toggling one or more of them outside of Cayenne, please let me know.


Dear Mr. Siegel,

thanks for your reply, but my DS18B20 sensor is still not being detected from your software even though I enable 1Wire via raspi-config :

I am also aware that under normal curcumstances the software should auto-detect the sensor.

Also I cannot see anything when going to GPIO Tab and my RAM is 96% constant. I tested on a friend’s Rasperry PI 2 the same sensor configuration without problems . He is also seeing the GPIO tab on his dashboard. I am starting to think this is either an installation problem or my device is somewhat not compatible with Cayenne . Please advise the easiest way to uninstall / reinstall the software . Btw I already tried removing the device and reinstalling it via my Smartphone several times but the issue persists.


I think a re-install sounds like a good idea considering that it worked on your friend’s set up. To do so, run the following commands on your Pi:

sudo /etc/myDevices/uninstall/./


sudo /etc/webiopi/uninstall/./

To re-install, just log into your Cayenne account at and use Add New… > Device and follow the on-screen instructions.


Thanks ! It seems now definitely an installation problem as I don’t see myDevices folder in /etc/. I see only the second one /etc/webiopi/uninstall/./ . Should I proceed with just /etc/webiopi/uninstall/./ ? Or is there a myDevices folder somewhere else ?


I’m guessing we uninstalled the /etc/myDevices folder when you were removing the Pi from the Android app, our uninstall triggered that way just needs to be updated to remove the /etc/webiopi folder as well. There is no other myDevices folder that you should have to look for.

So yeah, go ahead and proceed with the 2nd command, then attempt to re-add the Pi and see if you have any better results.


I executed the command, here is the output :

sudo /etc/webiopi/uninstall/
Synchronizing state for webiopi.service with sysvinit using update-rc.d…
Executing /usr/sbin/update-rc.d webiopi defaults
Executing /usr/sbin/update-rc.d webiopi disable
insserv: warning: current start runlevel(s) (empty) of script webiopi' override s LSB defaults (2 3 4 5). insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of scriptwebiopi’ o verrides LSB defaults (0 1 6).
cat: /installed_components: No such file or directory

I am currently installing again via Smartphone … Will let you know of results when its finished.


Thanks. Just for the record that is the expected output from uninstalling webiopi, so no issues there.


Hello ,

smartphone installation is now complete but I am still not able to see the sensor / GPIO Tabs.:frowning: Also right afer install completes on LG D618 smartphone I see again promt to install raspberry


At this point, considering that this worked OK on your friend’s set up, I don’t have any reason to suspect your wiring, and think it could be a good idea to try a fresh Jessie reinstall on your Pi. If you’re using it for a lot more than this project and don’t want to lose what you’ve got set up, let me know and we can continue troubleshooting without a Fresh OS – I just suspect this might help in the interest of time, by providing a known starting position.

If you go ahead with that re-install, i would remove that Pi instance from your account by tapping it, then the Settings gear icon > General > Remove Device so you can add it fresh on the fresh system.


I will have to rethink my options right now as I have several other projects on my SD card that I would not like to lose via flashing and besides I am able to access the sensor via sys/bus/w1/devices and I already tested a working python script solution that displays my room temperature at a given interval. Anyways thank you very much for your assistance. Please do not close this topic yet. I might write again in the coming weekend. Wishing you a nice evening for now.


It should really never be necessarily to do a full wipe, we just encounter a lot of users with a Pi dedicated to the project, so I thought I’d try the easy way :slight_smile:

Glad that you’ve got this working for your needs outside of the platform, and I’ll look into further troubleshooting ideas so you can eventually get this into Cayenne.