DS18B20 Temperature Setup


#1

1. Is this related to iOS or the online dashboard?

Dashboard


2. Please describe the issue you are experiencing in as much detail so we can quickly resolve.

The installation of DS18B20 temperature sensors is a bit hit and miss. I have managed to enter just DS18B20 into the Enter Slave box and click save and after some time / re-boot / reset display it just starts working.
At present I have one half installed ? DS18B20 giving a live plot of a -ve 7 digit number… I can not un install it using Remove Sensor’ as the button is pale / not an active option at the moment. Have tried to reset the display to clear this issue. I have tried a few re-boots. It is still sitting there if you want to ‘look into’ it. Feel free to log in.
~ Andrew


#2

Hi Andrew,

This is actually a feature…we automatically detect one-wire sensors on GPIO pin 4 (when wired correctly of course) and put it in the dashboard.

Good or bad feature in your eyes? Or maybe confusing if you don’t know about it?

-B


#3

Hi what happens if the device (DS18B20) was found but was then removed.
I tried rebooting but this time it does not get added, is there a way to get Cayenne to add it again?

Walter


#4

I understand adding a DS18B20 should happen automatically, but what if it does not?
Can I add this manually a Dallas DS1820, it is NOT the “B” version. Do I need it to be the a DS18B20 or will the DS1820 still work ok?

Walter


#5

When entered a device manually it asks to enter a slave value, what would I enter here for a DS1820. I do not see much in terms of the slave field in the documentation. I did see mention of it for a different sensor. Could you prevent the display of the slave field if it is not required for a certain device?


#6

Is your device detected by the pi? Run these commands and post back the output:

cd /sys/bus/w1/devices/
ls


#7

Hello, I’m having the same issue the ds18b20 was working then it disappeared. Here’s what I get from enter the code below. raspberrypi:/sys/bus/w1/devices ls 00-2e8000000000 00-ae8000000000 w1_bus_master1 pi@raspberrypi:/sys/bus/w1/devices

Is it possible the the Ds18b20 has went bad?


#8

edit sudo nano /boot/config.txt and add dtoverlay=w1-gpio if it is not present. reboot your pi and login.
next run the following and post the output here.

 sudo modprobe w1-gpio
 sudo modprobe w1-therm
 cd /sys/bus/w1/devices
 ls
 cd 28-xxxx (change this to match what serial number pops up)
 cat w1_slave

#9

Here’s what I got

.Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Aug 27 07:58:45 2018 from 10.0.1.186
pi@raspberrypi:~ sudo modprobe w1-gpio pi@raspberrypi:~ sudo modprobe w1-therm
pi@raspberrypi:~ cd /sys/bus/w1/devices pi@raspberrypi:/sys/bus/w1/devices ls
00-0a2000000000 00-4a2000000000 00-8a2000000000 w1_bus_master1
pi@raspberrypi:/sys/bus/w1/devices cd 28-xxxx (change this to match what serial number pops up) -bash: syntax error near unexpected token `(' pi@raspberrypi:/sys/bus/w1/devices cat w1_slave
cat: w1_slave: No such file or directory
pi@raspberrypi:/sys/bus/w1/devices $

Thanks, Adam


#10

you have made changes to config.txt then it looks like you have pi has not detected the sensor.
follow this tutorial for hardware connection https://learn.adafruit.com/adafruits-raspberry-pi-lesson-11-ds18b20-temperature-sensing/overview